Rockbox Technical Forums

Support and General Use => Audio Playback, Database and Playlists => Topic started by: Proxima on April 08, 2007, 04:24:52 PM

Title: Database initialization seems stuck
Post by: Proxima on April 08, 2007, 04:24:52 PM
   I'm using a Gigabeat f10 here and when I initialize the database I see it quickly climb the numbers until it reaches 1406, and it never goes past that number. I can't play music at the moment because when I go to play it through the files it just gives me a blank screen (it contains the artists and albums but no more) and no sound. I am able to get to a 'now playing screen' through the icon labeled "root" under the files menu but it says "No file!" Also the battery seems to drain very quickly whenever the gigabeat is turned off. Anyone think they know what's going on?
Title: Re: Database initialization seems stuck
Post by: bluebrother on April 08, 2007, 04:43:32 PM
How old is your build? There was an issue that got fixed recently, so unless your build is really fresh you should update.

Besides, there is no icon labelled "root" -- what exactly are you referring to?
Title: Re: Database initialization seems stuck
Post by: Proxima on April 08, 2007, 06:50:17 PM
My build is from yesterday, but I can try updating again. As for the mysterious "root":  Under the main menu I go to files, which brings us music, my music, pictures etc. and at the bottom there are two icons that don't seem to belong:  "batter_bench," which I believe is a plugin I attempted to run when I was first experimenting with rockbox, and "root" which appeared after I tried to make a playlist (didn't work). Both of their icons consist of three horizontal lines as opposed to the folder icon, if that is of any help.
Title: Re: Database initialization seems stuck
Post by: Febs on April 08, 2007, 07:09:49 PM
That is a playlist file that you created using the "create playlist" function.  It was created at the root directory level, and therefore has the name "root.m3u."

You should read the "Browsing and Playing" chapter of the manual to understanding how to browse and play music in Rockbox.
Title: Re: Database initialization seems stuck
Post by: Proxima on April 08, 2007, 11:54:03 PM
Ahh, thank you. I didn't catch the part about the root playlist in the menu. The real dilemma, though, for me is that no actual music can be played on the player. The file names of the artists and albums are all there, but past that I get nothing. Also, when I tried hooking it up to the computer, the device is not recognized as an mp3 player and therefore I can't sync music to it. Windows media player and napster don't acknowledge the presence of a player.  

The problem, I'm thinking, has to do with the fact that the database never finishes building itself.
Title: Re: Database initialization seems stuck
Post by: Llorean on April 09, 2007, 12:44:10 AM
Wait, so was all the music synced to it in the original firmware, pre-Rockbox?

None of that music will work, it's encrypted.
Title: Re: Database initialization seems stuck
Post by: Proxima on April 09, 2007, 11:43:28 AM
Oh... Well I feel bright. But if that is encrypted then how would I go about putting music on it? I can't seem to coax windows media player into recognizing the device.
Title: Re: Database initialization seems stuck
Post by: Febs on April 09, 2007, 01:35:14 PM
Just drag and drop using Windows Explorer.
Title: Problem Solved
Post by: Proxima on April 09, 2007, 06:55:15 PM
Yeah it's working now. Man I feel like an idiot. Thanks for the patience guys.