Rockbox Technical Forums

Installation / Removal => Manual Installation => Toshiba - Installation/Removal => Topic started by: John Poplett on March 10, 2007, 07:54:54 PM

Title: Database initialization / update
Post by: John Poplett on March 10, 2007, 07:54:54 PM
Hi, all

I followed the installation instructions and have rockbox installed and running on my F40. I am trying to get the database initialized and updated but have not had success yet.

When I invoke the command

General Settings -> Database -> Initialize Now

I get a prompt that says "building database... XXX records (OFF to return)"

When I press off, the unit seems to power off and go into a DEEP sleep. I don't hear the HD running and pressing the power button will not restart the unit. To get the unit to start back up, I have to toggle the battery off and on. When I power up, the database status is

initialized -> yes
DB ready -> no
Progress (1% - 0 entries)
Commit step: 0
Commit Delayed: No

I am using the current build from today (Mar 10).

Is there something I'm doing wrong or can someone suggest a better way?

Thanks,

John



Title: Re: Database initialization / update
Post by: John Poplett on March 11, 2007, 12:02:47 PM
On a hunch, I backed up and then removed my old "My Music" directory which had about 4,000 SAT encrypted music files in it. The database initialization / update function apparently was either choking on the presence of SAT files or the # of them. There were also some quantity of unencrypted MP3 files.

I then created a My Music directory with only MP3s and WMAs in it. The next attempt at database initialization / update ran to completion in a matter of seconds.

Problem solved but the route to a solution was a bit rough.

John
Title: Re: Database initialization / update
Post by: pixelma on March 12, 2007, 05:38:16 AM
I then created a My Music directory with only MP3s and WMAs in it.

I hope you are aware that Rockbox cannot play .wma files. It supports a lot of different sound formats but wma is not part of it ((yet)).
Title: Re: Database initialization / update
Post by: Lapoot on November 16, 2007, 06:26:14 PM
Hi Friends, I've using Rockbox for a couple of months...happily on my f40.  Until I finally decided to pursue why I have no albums.

The database initialization I believe is my glitch. I can remove the database_tmp.tcd and it will go through the initial search and then ask to reboot. Takes about 90 seconds.

After rebooting, the database_tmp.tcd file is back, database is NOT initialized and it shows no files... and obviously no albums.

I've tried looking for the right place (topic) in the forums to address my issue to no avail.
PS - also have installed current builds over the last two weeks.

Any Ideas   - or where is the answer?
Thanks, Lapoot
Title: Re: Database initialization / update
Post by: Llorean on November 16, 2007, 06:31:24 PM
This thread wasn't about Installation/Removal in the first place, and it really doesn't need new posts about different problems.