Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: RufusA on September 07, 2018, 09:42:51 AM

Title: Are the Rockbox IRC Logs broken?
Post by: RufusA on September 07, 2018, 09:42:51 AM
...or has no-one spoken on the Rockbox IRC since 19th August?


Title: Re: Are the Rockbox IRC Logs broken?
Post by: Bilgus on September 07, 2018, 10:33:50 AM
Freenode IRC has been getting hit with hundreds of spam messages so now there is a requirement to be registered in order to join and it killed off the log bot

Here is what I have of the log Aug 01 - today

Code: [Select]

Aug 01 05:08:00 <edhelas> hello o/
Aug 01 07:47:13 * gevaerts tries things...
Aug 01 07:48:22 <gevaerts> *maybe* the next one will be kicked
Aug 01 07:48:30 <gevaerts> Or maybe I've done things wrong of course
Aug 01 07:51:54 <Tux11> With our IRC ad service you can reach a global audience
of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https
Aug 01 07:51:55 * gevaerts has kicked Tux11 from #rockbox (Tux11)
Aug 01 08:08:56 <Thorne4> With our IRC ad service you can reach a global audienc
e of entrepreneurs and fentanyl addicts with extraordinary engagement rates! htt
Aug 01 08:08:56 <Thorne4> I thought you guys might be interested in this blog by
 freenode staff member Bryan 'kloeri' Ostergaard
Aug 01 08:08:56 * gevaerts has kicked Thorne4 from #rockbox (Thorne4)
Aug 01 08:17:53 <ovoldemorto> With our IRC ad service you can reach a global aud
ience of entrepreneurs and fentanyl addicts with extraordinary engagement rates!
Aug 01 08:17:54 * gevaerts has kicked ovoldemorto from #rockbox (ovoldemorto)
Aug 01 08:19:33 <F4RR3LL> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! htt
Aug 01 08:19:33 * gevaerts has kicked F4RR3LL from #rockbox (F4RR3LL)
Aug 01 08:55:16 <ninsei12> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! ht
Aug 01 08:55:17 * gevaerts has kicked ninsei12 from #rockbox (ninsei12)
Aug 01 09:06:04 <Guest92107> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates!
Aug 01 09:06:04 * gevaerts has kicked Guest92107 from #rockbox (Guest92107)
Aug 01 09:37:09 <Ambroisie> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! h
Aug 01 09:37:09 * gevaerts has kicked Ambroisie from #rockbox (Ambroisie)
Aug 01 10:01:02 <Kingsy2> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! htt
Aug 01 10:01:02 <Kingsy2> I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard
Aug 01 10:01:02 <Kingsy2> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal
Aug 01 10:01:02 * gevaerts has kicked Kingsy2 from #rockbox (Kingsy2)
Aug 01 10:54:06 <red-00121> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! h
Aug 01 10:54:06 <red-00121> I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard
Aug 01 10:54:06 <red-00121> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal
Aug 01 10:54:06 <red-00121> A fascinating blog by freenode staff member Matthew 'mst' Trout
Aug 01 10:54:06 * gevaerts has kicked red-00121 from #rockbox (red-00121)
Aug 01 10:57:34 <tcsc6> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https
Aug 01 10:57:34 * gevaerts has kicked tcsc6 from #rockbox (tcsc6)
Aug 01 11:03:04 <deltam> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! http
Aug 01 11:03:04 * gevaerts has kicked deltam from #rockbox (deltam)
Aug 01 11:09:22 <Lord_of_Life7> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rate
Aug 01 11:09:22 <Lord_of_Life7> I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard https://bryanostergaard.c
Aug 01 11:09:22 <Lord_of_Life7> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal
Aug 01 11:09:22 * gevaerts has kicked Lord_of_Life7 from #rockbox (Lord_of_Life7)
Aug 01 11:25:19 <Raito_Bezarius25> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement r
Aug 01 11:25:19 * gevaerts has kicked Raito_Bezarius25 from #rockbox (Raito_Bezarius25)
Aug 01 11:31:44 -christel- : [Global Notice] Hi all, we are aware of the current spambot attacks, and we would encourage users to set themselves +R and channel
operators to set +r in the channels while the attack is ongoing. While our mitigating efforts are catching the vast majority at the gate, a small proportion sti
ll make it through. Apologies for the inconvenience and please bear with us as we do our best to minimize impact.
Aug 01 11:34:05 <siinus`18> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! h
Aug 01 11:34:05 * gevaerts has kicked siinus`18 from #rockbox (siinus`18)
Aug 01 11:41:25 * gevaerts sets mode +r on #rockbox
Aug 02 05:17:50 <SmokedCheese> Hello! How I can install rockbox on iPod on macOS if iTunes keeps automounting it?
Aug 02 05:22:44 <SmokedCheese> it's already in windows format
Aug 02 11:30:56 <__builtin> hi SmokedCheese
Aug 02 11:55:06 <__builtin> I remember of windows that you need to kill some helper process that does the automount, but I'm not sure about mac
Aug 03 02:43:27 <SmokedCheese> __builtin there's option to disable device automount in iTunes' iPod settings lol
Aug 03 20:21:47 * __builtin removes channel operator status from __builtin
Aug 06 03:32:46 <paulk-leonov> hi there, looks like the lyre project webpage is down
Aug 06 05:51:11 <edhelas> hi everyone :)
Aug 07 22:33:25 * devponies[m] wonders if mt32emu can be ported to rockbox
Aug 07 23:12:40 <__builtin> devponies[m]: C++, so "probably not"
Aug 07 23:13:46 <__builtin> I managed to port "Another World", which was also C++, but only with a line-by-line rewrite
Aug 08 03:12:44 <devponies[m]> aww
Aug 08 03:12:48 <devponies[m]> but mt32emu is useful
Aug 08 03:13:10 <devponies[m]> especially if you can somehow get it to emulate a midi device over usb
Aug 09 23:18:16 <saratoga> are wiki registrations disabled?  someone on the forums said they couldn't get access
Aug 10 00:10:25 <Bilgus> I wasn't able to register either so i'd say they are
Aug 10 21:11:02 <flashpoint> how difficult would it be to get the iriver h300 to do usb OTG
Aug 10 21:11:22 <flashpoint> does it have a kernel or... something
Aug 10 21:12:06 <flashpoint> how would one go about putting a driver into the bootloader
Aug 11 13:02:46 <kachmi> does anyone know if the site's registration page is working? I've tried a few times, but haven't recieved an account activation email..
Aug 11 13:36:03 <et09> i had a sansa clip ... looking for a rockbox compatible replacement... 120gb support if possible - any tips?
Aug 11 13:45:28 <__builtin> kachmi: I think it's either broken or intentionally disabled
Aug 11 13:45:33 <__builtin> something about spambots
Aug 11 14:03:52 <kachmi> ah, ok. Thanks __builtin
Aug 11 14:06:35 <kachmi> et09: I recently replaced my old Fuze with an AGPTEK Rocker running rockbox and am liking it so far
Aug 11 14:08:14 <kachmi> the layout of its buttons is similar to the clip
Aug 11 14:10:28 <kachmi> haven't tried a 120 gb chip in it yet though...
Aug 11 14:14:39 <et09> ic
Aug 11 14:16:52 <et09> rockbox is still the main mp3 player firmware thing right?
Aug 11 14:19:22 <__builtin> et09: what do you mean by "main"?
Aug 11 14:19:35 <et09> idk, dumb question
Aug 11 14:19:54 <et09> meaning there aren't any other big mp3 player firmware software hack-ons
Aug 11 14:21:39 <__builtin> not on the scale of rockbox
Aug 11 14:22:17 <__builtin> there is/was the s1mp3 project, but that's for a different range of devices, and it's much smaller
Aug 11 14:22:22 <__builtin> and it's largely dead
Aug 11 14:24:06 <et09> disappointed with the mp3 player market in 2018
Aug 11 14:24:27 <et09> new sandisks not rockboxable and competitors are meh
Aug 11 14:24:51 <et09> any complaints about the agptek kachmi ?
Aug 11 14:30:36 <kachmi> nothing major
Aug 11 14:31:21 <kachmi> overall it seems to be well constructed
Aug 11 14:31:36 <et09> real use battery life ?
Aug 11 14:32:27 <kachmi> the batter lasts pretty well
Aug 11 14:32:59 <kachmi> I had it running 12 hours on low-medum volume once and it still wasn't cmopletely discharged
Aug 11 14:33:27 <et09> that's good
Aug 11 14:33:50 <et09> tearing my place apart looking for my sansa clip, i think its battery is dead but want to check
Aug 11 14:34:25 <kachmi> and it's run for at least 3 on louder settings too with about half charge remaining
Aug 11 14:35:09 <kachmi> haven't actually run out of battery while listening yet, so not sure about the maxiumum runtime
Aug 11 14:35:41 <et09> review on that one seem a little lukewarm, but mostly ppl complaining about software i think
Aug 11 14:35:56 <et09> reviews*
Aug 11 14:38:17 <et09> which version?
Aug 11 14:38:44 <et09> v2, v4 etc
Aug 11 14:39:17 <kachmi> I have the v2
Aug 11 14:43:03 <et09> funny how the dedicated computer hwardware manufacturers make the best ones
Aug 11 15:13:38 <et09> awesome i found my sansa clip
Aug 11 15:13:49 <et09> i thought it was gonna be in the last place i looked, but it turned out it was in the second to last place i looked
Aug 11 22:54:12 <flashpoint> hi, is there a patch for the h300 for ssd?
Aug 11 22:54:57 <flashpoint> I don't think the several dollar adapter is converting anything, the spindown and all that other stuff is still being controlled by
 the bootloader isn't it?
Aug 11 22:55:33 <flashpoint> this is the hotwiring a car of msata ssd conversions
Aug 13 14:52:21 <__builtin> user890104: can you read Russian?
Aug 14 04:10:41 <gyuritzy> Hello
Aug 14 04:12:58 <gyuritzy> @gevaerts can I ask you something? Do you know hor to install original firmware to Creative ZEN X-Fi?
Aug 14 07:04:44 <gyuritzy> join #gevaerts
Aug 14 07:04:47 <gyuritzy> oups
Aug 16 15:59:26 <cereal_K> Anyone here, who is subscribed to the mailing list?
Aug 16 15:59:45 <cereal_K> I just subscribed, but I don't have ols messages in my inbox.
Aug 16 16:00:08 <cereal_K> sorry, old messages..
Aug 16 16:01:16 <cereal_K> Would anyone tell me the e-mail address of the Author of thes message with the subject "Give away: iAudio X5L (partial)"
Aug 16 16:02:02 <cereal_K> The name is Aura Kelloniemi
Aug 16 16:02:57 <cereal_K> That would be nice.
Aug 16 16:34:40 <cereal_K> I need to go, but I'll read the logs, if someone is replying. Thanks in advance.
Aug 17 08:41:32 <ac_laptop> hello people ! _o/
Aug 17 08:41:36 <ac_laptop> how is the project going ?
Aug 18 11:43:35 <Gyuritzy> Hello Pamaury
Aug 18 11:43:41 <pamaury> hi
Aug 18 11:43:53 <Gyuritzy> I need your help
Aug 18 11:44:46 <Gyuritzy> I have some problem installing original firmware on a creative zen x-fi
Aug 18 11:45:15 <Gyuritzy> I used your bootloader to wake up my creative
Aug 18 11:46:05 <pamaury> ah maybe you are the person who sent me an email? I am way behind on email/messages, I have been busy with real life.
Aug 18 11:46:14 <Gyuritzy> But when I try sendfirm, I get an error message Error occured during sending
Aug 18 11:46:18 <pamaury> So to clarify, you want to reinstall the OF?
Aug 18 11:46:26 <Gyuritzy> Yes
Aug 18 11:46:56 <Gyuritzy> I am using windows xp sp3
Aug 18 11:47:03 <pamaury> ok, so the usual way to do it is to 1) boot in recovery, 2) select Reload firmware in the menu, 3) use sendfirm to send the original f
Aug 18 11:47:33 <Gyuritzy> I have uninstalled wmp11 and put wmp10
Aug 18 11:48:04 <Gyuritzy> I can not boot my creative without your bootloader the one with fresc
Aug 18 11:49:00 <Gyuritzy> I send the booloader, then I try erase firmware
Aug 18 11:49:29 <Gyuritzy> But at the end I get a quick dissapearing error message
Aug 18 11:49:40 <pamaury> you mean your device boots in hardware recovery mode (black screen, special USB ID)?
Aug 18 11:50:05 <Gyuritzy> I think yes...
Aug 18 11:50:19 <pamaury> ok that's weird
Aug 18 11:50:19 <Gyuritzy> I have a black screen
Aug 18 11:50:31 <Gyuritzy> And sendfirm is not working
Aug 18 11:50:42 <pamaury> did you reflash the true bootloader ever or did it just happen one day?
Aug 18 11:51:08 <Gyuritzy> I tried to load rockbox
Aug 18 11:51:25 <Gyuritzy> But I failed at formatting
Aug 18 11:51:40 <Gyuritzy> I am not sure
Aug 18 11:52:06 <Gyuritzy> But I never installed the bootloader of rockbox
Aug 18 11:52:16 <Gyuritzy> Or?
Aug 18 11:52:53 <Gyuritzy> You think that I succeeded sending a rockbox booloader?
Aug 18 11:53:00 <pamaury> I see, sounds like it may be a hardware problem but I am not sure. If you load the original FRESC, what happens exactly?
Aug 18 11:53:41 <Gyuritzy> I get the creative screen and the reboot and the I get the recovery screen
Aug 18 11:54:02 <Gyuritzy> With format and erase firmware
Aug 18 11:54:24 <Gyuritzy> If I format, the screen gets black
Aug 18 11:55:09 <Gyuritzy> If I choose reload firmware I get an media error message and then it dissapeares
Aug 18 11:55:43 <Gyuritzy> And sendfirm gets me an error occured durind sending
Aug 18 11:56:37 <pamaury> Ok, so I see two possible explanations: 1) your flash is dead, thus rockbox and OF cannot access it which explains the crashes, 2) the
 proprietary partition table on the flash was somehow modified/corrupted
Aug 18 11:57:07 <pamaury> If you give me say 15min, I can build and send you a modified FRESC to test either theory
Aug 18 11:57:50 <Gyuritzy> No problem, thanks for your time
Aug 18 11:58:07 <Gyuritzy> I try to connect from my pc
Aug 18 12:02:55 <gyuritzy_> I am connected from my pc with the user gyurity_
Aug 18 12:13:02 <pamaury> I have a prototype, but I just realized I can't test it on my xfi because I cannot boot in hardware recovery mode (it requires to open
 the device and disconnect the battery)
Aug 18 12:13:27 <pamaury> I can send you the file for you to try though
Aug 18 12:13:41 <gyuritzy_> ok
Aug 18 12:13:51 <gyuritzy_> I will try
Aug 18 12:14:01 <pamaury> give me a minute, I will upload it
Aug 18 12:14:52 <pamaury>
Aug 18 12:15:01 <pamaury> you need to upload it using sbtool, just like FRESC
Aug 18 12:15:10 <gyuritzy_> I will have to send it to creative with sbloader right?
Aug 18 12:15:34 <pamaury> yes
Aug 18 12:15:52 <pamaury> if it works, you should see a black screen with some lines printed in white, and it should connect over USB as a disk. DO NOT FORMAT I
Aug 18 12:18:29 <gyuritzy_> something strange happened
Aug 18 12:19:17 <pamaury> what exactly?
Aug 18 12:19:58 <gyuritzy_> you are right
Aug 18 12:19:58 <gyuritzy_> I see the lines
Aug 18 12:21:56 <pamaury> out of curiosity, what does the battery line show? It's also possible your battery is super low, I've seen this behavior on older ZEN-
V devices
Aug 18 12:22:02 <pamaury> does it connect over usb as a disk?
Aug 18 12:23:11 <gyuritzy> sorry something heppened with my connection
Aug 18 12:23:40 <gyuritzy> are you still here?
Aug 18 12:23:49 <gyuritzy> so I see Boot version
Aug 18 12:23:56 <gyuritzy> I see Boot arg
Aug 18 12:24:01 <pamaury> yes I'm here
Aug 18 12:24:06 <gyuritzy> I see Boot addr
Aug 18 12:24:20 <gyuritzy> No partition found
Aug 18 12:24:29 <gyuritzy> USB connecting
Aug 18 12:24:39 <gyuritzy> Bootloader USB mode
Aug 18 12:24:55 <gyuritzy> charging status
Aug 18 12:25:02 <gyuritzy> topoffng
Aug 18 12:25:12 <gyuritzy> Battery 82%
Aug 18 12:26:15 <gyuritzy> Die temp 39`
Aug 18 12:27:25 <pamaury> ok so it seems to be working, mhmmmmm, and did Windows detect a device over USB?
Aug 18 12:28:54 <gyuritzy_> sorry
Aug 18 12:29:07 <gyuritzy_> I don't know what happened
Aug 18 12:29:17 <gyuritzy_> I keep loosing the connection
Aug 18 12:30:03 <gyuritzy_> are you still here?
Aug 18 12:30:06 <pamaury> yes
Aug 18 12:30:19 <gyuritzy_> did you see whatI wrote?
Aug 18 12:30:29 <gyuritzy_> what should I see?
Aug 18 12:30:57 <gyuritzy_> it says gyuritzy has quit :(
Aug 18 12:31:09 <pamaury> did Windows detect a device over USB?
Aug 18 12:31:33 <gyuritzy_> yes
Aug 18 12:32:02 <gyuritzy_> I see 2 additional drives
Aug 18 12:32:25 <gyuritzy_> butI can not acces them
Aug 18 12:33:51 <gyuritzy_> what should I see?
Aug 18 12:34:19 <pamaury> Well on Windows I don't know, I only use Linux. I don't expect Windows to be able to open any partition
Aug 18 12:34:58 <pamaury> I suppose you don't have access to Linux?
Aug 18 12:35:54 <gyuritzy> hello
Aug 18 12:37:40 <gyuritzy__> what is happening
Aug 18 12:37:54 <gyuritzy__> I am thrown out...
Aug 18 12:37:58 <pamaury> gyuritzy__: on disconnect, read to see the IRC logs, it avoids repeating things
Aug 18 12:38:34 <pamaury> which software are you using for IRC?
Aug 18 12:39:33 <gyuritzy__> firefox
Aug 18 12:40:35 <pamaury> ok, strange that it doesn't work
Aug 18 12:40:53 <gyuritzy__> the battery is at 82%
Aug 18 12:41:05 <gyuritzy__> it seems ok now
Aug 18 12:41:16 <gyuritzy__> what can I do at this point?
Aug 18 12:41:24 <pamaury> gyuritzy__: did you see my comment about ?
Aug 18 12:41:36 <gyuritzy__> about linux/
Aug 18 12:41:38 <gyuritzy__> ?
Aug 18 12:41:41 <pamaury> you can read the log so that we don't have to repeat things all the time.
Aug 18 12:42:08 <pamaury> Well if you have a simple way of running linux that would help, otherwise I will need a bit of time to write something that runs under
Aug 18 12:42:19 <pamaury> I don't really know what is the problem at this point
Aug 18 12:42:59 <gyuritzy__> I can only run a bootable linux
Aug 18 12:43:06 <gyuritzy__> but I am newby
Aug 18 12:43:18 <gyuritzy__> I can not use it really
Aug 18 12:43:44 <pamaury> the simplest thing to do is to dump part of the disk and send me the data so I can inspect it. That should be doable even under Window
Aug 18 12:44:04 <gyuritzy__> oh...
Aug 18 12:44:09 <gyuritzy__> how?
Aug 18 12:44:36 <pamaury> I don't know yet :P Give me some time, I have Windows in a virtual machine so I can see what options we have :)
Aug 18 13:01:35 <gyuritzy__> is there any way to install the original firmware in this stadium?
Aug 18 13:04:30 <pamaury> well the usual way to install the original firmware is to use sendfirm
Aug 18 13:04:48 <pamaury> but in your case it seems like Creative's bootloader is failing for some reason
Aug 18 13:05:05 <gyuritzy__> ok
Aug 18 13:05:18 <gyuritzy__> :(
Aug 18 13:06:13 <gyuritzy__> at the end of update firmware I get a short message media error on the display of my xfi
Aug 18 13:06:30 <gyuritzy__> then its back to the same screen
Aug 18 13:06:57 <gyuritzy__> If I try again to update firmware... it turns the screen black
Aug 18 13:07:18 <gyuritzy__> and sendfirm is giving me an error
Aug 18 13:08:02 <pamaury> stupid question but are you 100% sure you are sending the right file with sendfirm?
Aug 18 13:08:48 <gyuritzy__> I am sending the file ZENXFI_PCFW_L22_1_04_08e_rk.bin
Aug 18 13:09:38 <gyuritzy__> I think you posted it in the forum
Aug 18 13:10:14 <gyuritzy__> is it the corect one?
Aug 18 13:10:18 <pamaury> yeah sounds correct
Aug 18 13:13:03 <gyuritzy__> could it be the sendfirm.exe which is not correct?
Aug 18 13:13:55 <gyuritzy__> you also had to rewrite sbloader to send the bootloader to the zen xfi...
Aug 18 13:14:19 <gyuritzy__> something with smp3700...
Aug 18 13:15:03 <pamaury> both are heavily tested, it would be surprising
Aug 18 13:15:24 <pamaury> sbloader works since you successfully loaded my modified FRESC
Aug 18 13:15:48 <gyuritzy__> but not any sbloader
Aug 18 13:17:04 <gyuritzy__> sb_loader 246kb does not work
Aug 18 13:17:11 <gyuritzy__> and also sbloader_1
Aug 18 13:17:17 <gyuritzy__> is not working
Aug 18 13:20:14 <gyuritzy__> is it possible to send the original firmware with sbloader?
Aug 18 13:20:52 <pamaury> I don't know what are those sbloader_1 and sb_loader
Aug 18 13:20:56 <pamaury> no it's not possible
Aug 18 13:21:35 <gyuritzy__>,43626.15.html
Aug 18 13:21:39 <pamaury> maybe there are still old versions of the tools lying around
Aug 18 13:21:57 <gyuritzy__> you uploaded these files
Aug 18 13:23:17 <pamaury> sb_loader is Freescale's tool
Aug 18 13:23:51 <pamaury> we don't support sbloader on Windows, we only have a Linux version
Aug 18 13:24:51 <pamaury> our Linux version is more powerful, it supports devices that Freescale's tool does not (stmp3700 based devices mostly)
Aug 18 13:25:29 <gyuritzy__> you think that we could do more if I switch to linux?
Aug 18 13:25:42 <gyuritzy__> I also tried the sendfirm under linux...
Aug 18 13:25:47 <gyuritzy__> but to no avail
Aug 18 13:26:26 <pamaury> I kind of wrote a windows port of the tool at some point but it's unmainted.
Aug 18 13:26:35 <pamaury> If you can run linux that would be very helpful#
Aug 18 13:26:38 <pamaury> to debug
Aug 18 13:27:06 <gyuritzy__> but I can't do it by myself...
Aug 18 13:28:09 <pamaury> you mean you don't know how to run linux?
Aug 18 13:28:58 <gyuritzy__> no:-(
Aug 18 13:30:14 <gyuritzy__> I am newby in linux
Aug 18 13:31:28 <pamaury> ok, I will continue to try to make something work on Windows but I can't guarantee anything
Aug 18 13:31:28 <gyuritzy__> if you tell me the command... I can run it...
Aug 18 13:31:37 <pamaury> I can tell you what to run on linux
Aug 18 13:32:00 <pamaury> but you need to be able to at least boot linux and connect to the internet
Aug 18 13:32:11 <gyuritzy__> I try
Aug 18 13:32:29 <gyuritzy__> I will reboot my computer to boot linux
Aug 18 13:44:39 <gyuritzy> back online
Aug 18 13:45:09 <pamaury> are you on linux?
Aug 18 13:45:21 <gyuritzy> yes
Aug 18 13:45:52 <pamaury> ok, so you need to download
Aug 18 13:46:00 <pamaury> (note that this is not the same as previously)
Aug 18 13:46:44 <pamaury> and sbloader for linux:
Aug 18 13:50:49 <gyuritzy> what is the command?
Aug 18 13:51:39 <pamaury> to download?
Aug 18 13:51:51 <gyuritzy> to run sbloader
Aug 18 13:52:11 <gyuritzy> I tried sloader_32 but it says command notfound
Aug 18 13:52:24 <pamaury> ah ok, once you have it, open a terminal, make sure both files are in the same directory and run
Aug 18 13:52:24 <pamaury> ./sbloader_32
Aug 18 13:53:09 <gyuritzy> no device found
Aug 18 13:54:01 <pamaury> hmmm, try to run
Aug 18 13:54:01 <pamaury> lsusb
Aug 18 13:54:44 <pamaury> does it have a line that says Freescale or STMP recovery mode?
Aug 18 13:54:56 <pamaury> ah wait I'm stupid
Aug 18 13:55:13 <pamaury> you need to run it as root probably:
Aug 18 13:55:13 <pamaury> sudo ./sbloader_32
Aug 18 13:55:16 <gyuritzy> it says creative technology
Aug 18 13:55:52 <gyuritzy> no device found
Aug 18 13:55:54 <gyuritzy> the same
Aug 18 13:57:19 <pamaury> ah I remember now, Creative tweaked the usb ID, the version of sbloader_32 must be old. Can you give me the full line of lsusb that ha
s Creative technology?
Aug 18 13:58:29 <gyuritzy> Bus 001 Device 005: ID 041e:415a Creative Technology, Ltd
Aug 18 13:58:55 <gyuritzy> how long will you be here?
Aug 18 13:59:15 <pamaury> ok, so try this:
Aug 18 13:59:15 <pamaury> sudo ./sbloader_32 -b 041e:415a
Aug 18 13:59:19 <pamaury> all of tonight
Aug 18 13:59:32 <pamaury> ie for the next 4/5h or so
Aug 18 13:59:47 <gyuritzy> can I get backto you later? Sorry but I have to go now...
Aug 18 13:59:47 <pamaury> oops there is a mistake above
Aug 18 13:59:56 <pamaury> sudo ./sbloader_32 -u 041e:415a
Aug 18 13:59:58 <pamaury> sure no problem
Aug 18 14:01:03 <gyuritzy> cannot probe transfersize
Aug 18 14:01:17 <gyuritzy> please specify in comment line
Aug 18 14:01:31 <pamaury> sudo ./sbloader_32 -u 041e:415a -x 1024
Aug 18 14:01:43 <pamaury> not entirely sure this will work but let's see
Aug 18 14:03:52 <gyuritzy> transfer error at init step
Aug 18 14:04:55 <pamaury> okm unplug the device and replug, and try
Aug 18 14:05:01 <pamaury> sudo ./sbloader_32 -u 041e:415a -x 64
Aug 18 14:47:33 <gyuritzy> transfer error at init step
Aug 18 14:47:45 <gyuritzy> error cannot get status report
Aug 18 14:50:20 <pamaury> mhmmmm, this may require a kernel quirk, wait a minute
Aug 18 14:51:38 <pamaury> try the following:
Aug 18 14:51:38 <pamaury> rmmod usbhid && modprobe usbhid  quirks=0x041e:0x415a:0x0004
Aug 18 14:51:38 <pamaury> then unplug the device, replug it, and retry (first without the -x flag)
Aug 18 14:51:55 <pamaury> arg you will need sudo:
Aug 18 14:51:56 <pamaury> sudo rmmod usbhid && sudo modprobe usbhid  quirks=0x041e:0x415a:0x0004
Aug 18 14:52:33 <pamaury> and then (after you unpluged and replugged the device)
Aug 18 14:52:33 <pamaury> sudo ./sbloader_32 -u 041e:415a
Aug 18 14:53:38 <gyuritzy> error
Aug 18 14:53:54 <gyuritzy> could not insert usbhid
Aug 18 14:54:11 <gyuritzy> operation not permited
Aug 18 14:54:57 <gyuritzy> I forgot the second sudo
Aug 18 14:55:10 <gyuritzy> but another error
Aug 18 14:55:26 <gyuritzy> module usbhid is not currently loaded
Aug 18 14:55:57 <pamaury> ah, ok in this case just do the second one:
Aug 18 14:55:57 <pamaury> sudo modprobe usbhid  quirks=0x041e:0x415a:0x0004
Aug 18 14:57:21 <gyuritzy> aha
Aug 18 14:57:29 <gyuritzy> passed
Aug 18 14:58:07 <gyuritzy> device notifier rockbox media player
Aug 18 14:59:21 <pamaury> ok cool :)
Aug 18 15:00:00 <gyuritzy> aprox the same screen
Aug 18 15:00:02 <pamaury> ok now please run the following:
Aug 18 15:00:02 <pamaury> sudo dd if=/dev/sdb bs=1M count=1 of=zenxfi-short-dump.bin
Aug 18 15:00:13 <gyuritzy> the black one with small letters
Aug 18 15:00:43 <pamaury> if everything goes well, it should print something like "1+0 record read", "1+0 record write" or something like that. And you should h
ave a new file called zenxfi-short-dump.bin in the directory
Aug 18 15:02:01 <gyuritzy> dd unrecognized operand count
Aug 18 15:02:44 <gyuritzy> sorry misstype
Aug 18 15:02:53 <pamaury> ah ok, I was afraid ^^
Aug 18 15:03:42 <gyuritzy> I have it
Aug 18 15:03:48 <gyuritzy> the file I mean
Aug 18 15:03:55 <pamaury> can you email it to me, or upload it somewhere?
Aug 18 15:04:02 <gyuritzy> how can I send it to you
Aug 18 15:04:05 <gyuritzy> ?
Aug 18 15:04:46 <pamaury> you can email it to
Aug 18 15:04:46 <pamaury> or upload it on some sharing website online
Aug 18 15:08:07 <gyuritzy> I sent it to your e-mail
Aug 18 15:08:34 <gyuritzy> the one with
Aug 18 15:09:22 <pamaury> ok got it, let me have a look
Aug 18 15:10:31 <pamaury> ah I think we dumped the wrong disk
Aug 18 15:10:38 <pamaury> can you run
Aug 18 15:10:38 <pamaury> ls /dev/sd*
Aug 18 15:10:44 <gyuritzy> I sent it also on the other email adress
Aug 18 15:11:37 <gyuritzy> sda sda1 sda2 sdb sdc sdb1 sda5 sdd
Aug 18 15:11:51 <gyuritzy> with /dev/
Aug 18 15:11:54 <gyuritzy> in front
Aug 18 15:12:06 <pamaury> ok so can you please re-run the above command but replace /dev/sdb by /dev/sdc
Aug 18 15:12:22 <pamaury> sudo dd if=/dev/sdc bs=1M count=1 of=zenxfi-short-dump.bin
Aug 18 15:12:29 <pamaury> and send me the file again
Aug 18 15:12:42 <gyuritzy> no device
Aug 18 15:12:55 <pamaury> do you still have the device plugged?
Aug 18 15:13:04 <gyuritzy> yes
Aug 18 15:13:11 <pamaury> hmmm, ok try to unplug it first
Aug 18 15:13:24 <gyuritzy> panic
Aug 18 15:13:34 <pamaury> yes that's expected
Aug 18 15:13:34 <gyuritzy> bt end
Aug 18 15:13:42 <gyuritzy> plug it back?
Aug 18 15:13:53 <pamaury> first run
Aug 18 15:13:53 <pamaury> ls /dev/sd*
Aug 18 15:14:01 <pamaury> then press any button and replug it
Aug 18 15:14:39 <gyuritzy> done
Aug 18 15:14:48 <gyuritzy> but the same screen with panic
Aug 18 15:16:03 <gyuritzy> it is not detected
Aug 18 15:16:04 <pamaury> did you run ls /dev/sd*
Aug 18 15:16:10 <pamaury> it doesn't go awat if you press buttons?
Aug 18 15:16:18 <pamaury> if not, hit the reset button
Aug 18 15:16:18 <gyuritzy> no
Aug 18 15:16:28 <pamaury> (with a pen)
Aug 18 15:16:51 <gyuritzy> now the screen is black
Aug 18 15:17:06 <gyuritzy> I need to run sbloader again?
Aug 18 15:17:19 <pamaury> yes
Aug 18 15:19:32 <gyuritzy> I get the big list now
Aug 18 15:19:56 <gyuritzy> sdc and sdd is new
Aug 18 15:20:14 <pamaury> ok, now try again the command with /dev/sdc
Aug 18 15:20:48 <gyuritzy> No medium found
Aug 18 15:21:05 <pamaury> weird, do you have a SD card inserted or not?
Aug 18 15:21:07 <gyuritzy> dd: failed to open
Aug 18 15:21:24 <gyuritzy> no sd card
Aug 18 15:21:36 <pamaury> try with /dev/sdd
Aug 18 15:21:45 <pamaury> sudo dd if=/dev/sdd bs=1M count=1 of=zenxfi-short-dump.bin
Aug 18 15:21:47 <gyuritzy> also not working
Aug 18 15:22:21 <gyuritzy> should I delet the old file?
Aug 18 15:22:39 <pamaury> mmmh, can you run
Aug 18 15:22:39 <pamaury> sudo dmesg | tail -40
Aug 18 15:22:39 <pamaury> and copy paste the output on
Aug 18 15:22:46 <pamaury> no it doesn't make a difference
Aug 18 15:25:11 <gyuritzy> I pasted it
Aug 18 15:25:47 <pamaury> then press "Create new Paste" and write here the URL of the page
Aug 18 15:26:17 <gyuritzy>
Aug 18 15:27:12 <pamaury> that's really odd
Aug 18 15:27:27 <pamaury> can you retry
Aug 18 15:27:27 <pamaury> sudo dd if=/dev/sdc bs=1M count=1 of=zenxfi-short-dump.bin
Aug 18 15:29:36 <gyuritzy> still no medium found
Aug 18 15:30:06 <pamaury> that's not very good, maybe there is a problem with the flash of your device
Aug 18 15:30:20 <gyuritzy> ohno
Aug 18 15:30:43 <pamaury> I would need to modify the code to print more information to be sure
Aug 18 15:31:17 <gyuritzy> which code do you mean?
Aug 18 15:32:35 <pamaury> I will send you a modified FRESC later
Aug 18 15:33:03 <pamaury> (the code in the modified FRESC)
Aug 18 15:34:32 <gyuritzy> ok
Aug 18 16:29:22 <gyuritzy> when do you think you will make it? thanks.
Aug 18 16:47:52 <gyuritzy> could you please send me the file link to my e-mail adress?
Aug 18 16:48:21 <gyuritzy> I will retire this evening...
Aug 18 16:48:43 <gyuritzy> will you be here tomorrow?
Aug 18 16:56:56 <gyuritzy> have a nice evening/night
Aug 20 13:26:48 <ac> hello, has any sans fuze owner experienced issues with the jack connector ? has anyone heard some volume drops when the jack was slightly m
oving ?
Aug 20 13:27:49 <ac> I'm trying to disassemble my fuze but it seems that opening the case is not enoughto see what's happening when the jack is moving
Aug 20 13:28:30 <ac> the jack connector is attached to the PCB with a metal grip that is soldered to the PCB
Aug 20 13:29:27 <ac> that grip is a bit too wide, 0.1 mm maybe, and the connector is slightly moving
Aug 20 13:30:01 <ac> I have no idea what's happening in the zone where the jack and the PCB are supposed to be connected though
Aug 20 13:30:34 <ac> do they just touch ? are they soldered somehow ? or pinned ?
Aug 20 13:31:43 <ac> i'll try to remove the pcb
Aug 20 13:48:31 <ac> oh I see now
Aug 20 13:48:42 <ac> there are two little legs on each side of the connector
Aug 20 13:48:59 <ac> indeed one of them is broken
Aug 20 13:49:23 <ac> this would need soldering I guess
Aug 20 13:50:52 <ac> and I guess it's broken because there is a 0.1 mm play between the connector and its grip
Aug 20 13:51:16 <ac> the heat must have played a role too there
Aug 20 14:17:14 <Gyuritzy> Hello Amaury
Aug 20 14:49:52 <pamaury> Gyuritzy: hi, I'm on it ;)
Aug 20 14:57:46 <pamaury> Gyuritzy:
Aug 20 14:58:07 <pamaury> try this, it should print two lines with "init_drive(X): Y", please copy those lines
Aug 20 15:07:16 <Gyuritzy> it only writes one line
Aug 20 15:07:36 <Gyuritzy> init drive(0): -2
Aug 20 15:09:05 <pamaury> that's bad
Aug 20 15:09:48 <pamaury> it means the driver failed to initialise the flash becuse it timed out
Aug 20 15:11:12 <pamaury> which means your flash may have gone bad. We could try with a longer timeout but if it worked because there is little chance it's goin
g to work by suddendly waiting more
Aug 20 15:13:07 <Gyuritzy> stragne
Aug 20 15:13:19 <Gyuritzy> I tried once more... nothing happens
Aug 20 15:13:47 <Gyuritzy> Iwrote the command with -x 64
Aug 20 15:14:41 <pamaury> maybe sure to reset the device between runs, the hardware recovery is famously unreliable
Aug 20 15:15:19 <Gyuritzy> I reseted it but it only shows creative logo...
Aug 20 15:15:53 <Gyuritzy> is there any way to get out of this hardware recovery mode?
Aug 20 15:16:07 <pamaury> unplug the device
Aug 20 15:16:28 <Gyuritzy> also done
Aug 20 15:23:13 <Gyuritzy> the original FRESC is working
Aug 20 15:23:44 <Gyuritzy> hte "new" one is displaying the logo then the screen goes black
Aug 20 15:28:08 <pamaury> but it worked once right? Mayve retry several times
Aug 20 15:28:26 <pamaury> this is completely untested, I've never run a modified FRESC on the device
Aug 20 15:28:57 <Gyuritzy> I retried :-(
Aug 20 15:28:57 <pamaury> but in any case it seems your device has a problem, if even the original one fails with media error that's also a strong sign
Aug 20 15:29:53 <Gyuritzy> the original fresc also takes long to boot
Aug 20 15:30:59 <Gyuritzy> perhaps with longer timeout?
Aug 20 15:32:24 <pamaury> it won't change the black screen, AND it won't help with the original FRESC (that we need to use anyway to reflash)
Aug 20 15:33:46 <pamaury>
Aug 20 15:34:24 <pamaury> this is with a 10s timeout instead of 1s. If it still display init_drive: -2 then there is a no point looking further I think
Aug 20 15:39:00 <Gyuritzy> the screen remains black... it worked once... but now not any more
Aug 20 15:40:12 <pamaury> I don't know...
Aug 20 15:43:11 <Gyuritzy> I runned it 2 times one after another and the second time it launched but it says the same init drive(0):-2
Aug 20 15:44:06 <Gyuritzy> then no partition found
Aug 20 15:44:47 <Gyuritzy> it also wrtites disable partitions windows
Aug 20 15:46:45 <pamaury> it doesn't matter what it writes after, -2 means it didn't succeed in talking to the flash in this case
Aug 20 15:48:07 <Gyuritzy> just to be sure: no sd card is needed
Aug 20 15:49:47 <Gyuritzy> perhaps due to the unfinnished format, the flash was damaged...
Aug 20 15:57:17 <pamaury> that's very unlikely
Aug 20 15:57:31 <pamaury> the most common cause it's old age
Aug 20 15:58:15 <pamaury> or crappy flash firmware (internally it uses a FTL so when too many blocks go bad, usually firmwares fails and make the flash unusable
Aug 20 15:59:14 <Gyuritzy> can I do anything?
Aug 20 16:05:09 <pamaury> probably not
Aug 20 16:05:31 <pamaury> short of replacing the flash on the PCB, which is probably quite hard
Aug 20 16:07:32 <Gyuritzy> I think it is not worth it...
Aug 20 16:07:42 <Gyuritzy> sadly...
Aug 20 16:07:53 <Gyuritzy> it was a good player
Aug 20 16:08:54 <Gyuritzy> is there any way to format this flash?
Aug 20 16:09:39 <pamaury> no the firmware is integrated to the flash, it's all in one chip
Aug 20 16:10:39 <Gyuritzy> thank you for your time
Aug 20 16:10:58 <Gyuritzy> it seems this is the end of it...
Aug 20 16:18:10 <pamaury> sorry I can't do more :-/
Aug 20 16:18:43 <Gyuritzy> no problem. you have done enough. thanks again for your time
Aug 20 16:19:42 <Gyuritzy> have a nice evening
Aug 20 16:24:51 <Gyuritzy> by
Aug 21 14:37:33 * Disconnected (Remote host closed socket)
Aug 22 14:15:03 -emerson- :[Global Notice] Services are going to be rebooted for maintenance now, apologies for the inconvenience.
Aug 23 14:38:28 -emerson- [Global Notice] Unfortunately, due to the services disruption last night, we need to restart services again. We'll be doing this aroun
d 01:00UTC tomorrow. There will also be some netsplits afterwards as we continue to upgrade all of our servers, affected users will be sent notices before it ha
ppens. Sorry for the disruption, thanks for flying freenode :)
Aug 28 04:21:07 <gevaerts> tomf: I believe (but don't quote me on that, I'm not closely involved with the classic) it's dual boot and the installer integration.
 If the installation procedure doesn't daunt you and you don't need dual boot, it should be fine
Aug 28 04:25:39 <tomf> ok cool. Its for a dude on reddit. He can get a 6gen for $50 -- which is a pretty good deal. The manual installation is a breeze.
Aug 28 04:25:44 <tomf> thanks, gevaerts!
Aug 30 08:21:53 -mniip- [Global Notice] If you are using an IRC client that uses the "pango" text rendering library (e.g hexchat) or a terminal IRC client with
a terminal that uses pango, we advise that you make sure you've updated pango to the latest version. Windows users of hexchat are advised to update from the off
icial hexchat website:
Aug 31 10:22:09 <speachy> Hey, finally joining this channel.  I figure it's a better place than the forum to talk about my ongoing efforts to come up to speed o
n mips/jz74xx and the guts of rockbox
Aug 31 10:22:51 <speachy> to better figure out why the Xduoo X3 port is misbehaving
Aug 31 10:27:26 <gevaerts> speachy: welcome! irc does indeed work well for that sort of thing, *if* everyone involved is here. I'm not sure they are right now t
Aug 31 10:28:02 <speachy> c'est la vie
Aug 31 10:28:31 <speachy> I should be able to lurk here for a while.  Catching up on some mandatory training videos.
Aug 31 10:29:45 <speachy> I certainly picked a steep learning curve.
Aug 31 10:30:05 <gevaerts> You did :)
Aug 31 10:46:32 <speachy> Hmm.  Wiki registration is disabled.
Aug 31 15:01:01 <mendelmunkis> is it more likely to be a loose part or broken part?
Aug 31 16:56:46 <mendelmunkis> I have a fuze plus which started randomly crashing and also started to lose power every couple of minutes about 2 days after drop
ping it. it now does not power on or show up when connected to a computer
Aug 31 16:56:54 <mendelmunkis> is it more likely to be a loose part or broken part?
Sep 02 20:07:36 <speachy> Poking into the vorbis situation now.  Not even the test_codec plugin is working with a variety of ogg files I've tried.
Sep 02 20:07:59 <speachy> nothing useful in the log either
Sep 02 20:08:07 <mendelmunkis> if someone answered please repeat. my connection just went down for a min
Sep 02 20:13:20 <__builtin> mendelmunkis: nobody did :(
Sep 02 20:14:59 <__builtin> speachy: what happens with vorbis? a freeze or crash?
Sep 02 20:15:30 <speachy> __builtin:  Nothing at all, the track skips.
Sep 02 20:16:06 <speachy> test_codec shows it completing nearly instantly, although with a 0 size processed.
Sep 02 20:16:38 <speachy> just added a bunch of logging into the vorbis codec, to see how far it gets..
Sep 02 20:16:47 <__builtin> yeah, that's probably the way to go
Sep 02 20:17:09 <speachy> ... PANIC, audio_reset_buffer(): OOM
Sep 02 20:17:17 <speachy> huh..
Sep 02 20:19:37 <speachy> guess codec_main() doesn't like a ci->logf() call.
Sep 02 20:21:13 <speachy> I think the ov_open_callbacks() function is returning an error.
Sep 02 20:22:51 <speachy> error -132
Sep 02 20:26:23 <mendelmunkis> amiconn: Please invite logbot to the channel. It's the only way i can think of to restore logging without access to
Sep 02 20:27:09 <speachy> aka OV_ENOTVORBIS
Sep 02 20:27:26 <speachy> so the library is thinking it's not a valid file.
Sep 02 20:29:54 <__builtin> doesn't seem to work
Sep 02 20:32:21 <speachy> it's being compiled with the correct endianness...
Sep 02 20:34:17 <speachy> I wonder if this is a quirk of using a newer compiler.
Sep 02 20:41:24 <speachy> walking my way back through the library calls..
Sep 02 21:18:30 <speachy> okay, it's the vorbis header checksum code that's barfing
Sep 02 21:21:42 <speachy> #ifdef it out, and it's playing fine.  Not sure why yet; there's nothing obvious in there (and it works on the non-baremetal mips-base
d Rocker)
Sep 02 21:44:18 <speachy> this is strange.
Sep 02 21:50:21 <speachy> disabling a smaller chunk doesn't seem to work, even though logically it should be okay.
Sep 02 22:18:24 <speachy> well, enough out of this for one night..
Sep 02 22:21:32 <__builtin> speachy: endianness?
Sep 02 22:21:57 <__builtin> MIPS is bi-endian
Sep 02 22:22:59 <__builtin> oh, duh; I didn't read
Sep 03 08:11:14 <speachy> __builtin:  I checked that already; the code is being compiled (correctly) as little-endian.  And it works properly on the non-native
AGPTek Rocker target, which is the same family of SoCs.
Sep 03 10:29:26 <speachy> ...and also little endian
Sep 03 10:30:09 <speachy> there's no logging functionality available within the codec libraries themselves, from what I can tell.  So that severely limits easy
Sep 04 08:57:24 * gevaerts sets mode -r on #rockbox
Sep 04 08:57:44 * gevaerts removes quiet on $~a
Sep 04 08:59:05 <silent-newbie> hello!
Sep 04 08:59:44 * gevaerts sets quiet on $~a
Sep 04 09:01:13 * gevaerts sets mode -z on #rockbox
Sep 04 09:09:03 * gevaerts sets mode +r on #rockbox
Sep 05 11:59:07 <speachy> So, the latest joy is that the mips asm memset() is busted.
Sep 05 11:59:44 <speachy> I find myself wondering if everything else should be suspect too..
Sep 05 13:16:10 <diimdeep> Hello, trying to build from source, cloned from github mirror, used tools/, no errors, Make -> error!
Sep 05 13:17:03 <diimdeep>
Sep 05 13:17:28 <saratoga> huh is logbot not working?
Sep 05 13:18:23 <saratoga> diimdeep:  what are you trying to build?
Sep 05 13:18:44 <diimdeep> rockbox ;)
Sep 05 13:19:22 <diimdeep> Advanced -> Tests
Sep 05 13:19:50 <saratoga> what specifically?
Sep 05 13:19:57 <saratoga> your log doesn't have the configure step
Sep 05 13:20:58 <diimdeep> saratoga:
Sep 05 13:21:59 <speachy> logbot's been busted for about two weeks, apparently.
Sep 05 13:22:24 <saratoga> what folder are you building in?
Sep 05 13:22:37 <diimdeep> rockbox/build
Sep 05 13:22:40 <speachy> due to some sort of change on freenode's end, supposedly.
Sep 05 13:22:46 <saratoga> oh build
Sep 05 13:22:59 <diimdeep> BTW I need test_sampr.c plugin
Sep 05 13:24:05 <saratoga> clip+ should build fine
Sep 05 13:24:43 <diimdeep> Maybe i cloned broken revision
Sep 05 13:24:52 <diimdeep> should I checkout to tag
Sep 05 13:25:16 <saratoga> current git is usually best
Sep 05 13:25:29 <saratoga> i'm assuming that is what the mirror you're using provides
Sep 05 13:25:35 <saratoga> although i have no idea
Sep 05 13:28:53 <saratoga>;type=sansaclipplus
Sep 05 13:29:09 <saratoga> current git builds with no errors or warnings on the clip+
Sep 05 13:34:40 <diimdeep> tried to build from latest release source code archive
Sep 05 13:34:59 <diimdeep> same error must be misconfiguration
Sep 05 13:35:30 <diimdeep> although don't know how to fix(
Sep 05 13:36:00 <saratoga> what are you building on?
Sep 05 13:36:05 <diimdeep> macos
Sep 05 13:36:21 <saratoga> and you were able to build the arm compiler?
Sep 05 13:36:35 <diimdeep> yep
Sep 05 13:37:07 <saratoga> i remember it took me forever to get macos to build back in 2014 due to the apple toolchain weirdness
Sep 05 13:37:14 <diimdeep> ../tools/ --prefix=$(pwd)/local
Sep 05 13:37:16 <saratoga> no idea what they've changed since then
Sep 05 13:37:32 <diimdeep> export PATH="$(pwd)/local/bin:$PATH"
Sep 05 13:37:50 <diimdeep> I think this should work
Sep 05 13:40:47 <diimdeep> Omg I cloned official repo and it is building
Sep 05 13:43:00 <diimdeep> aand my dinner is cold, again..
Sep 06 06:07:57 <speachy> so, about the mips memset() b0rkage.
Sep 06 06:08:35 <speachy> can't stay here for long btw, will have to get the kiddo up for school in about half an hour
Sep 06 06:13:02 <speachy> the vorbis checksum code makes a single call to memset(), clearing 4 bytes at an unaligned position of a buffer.
Sep 06 06:13:38 <speachy> replacing the memset with explicit assignments works, as does completely disabling the asm memset() by deleting/renaming the mips/mems
et.S file.
Sep 06 06:14:58 <wodz> interesting
Sep 06 06:15:32 <speachy> because the asm memset() isn't clearing those 4 bytes properly, the checksum computation fails and the entire ogg block/frame gets dis
Sep 06 06:15:37 <wodz> are you able to tell how the address is unaligned? 1,2 or 3 bytes off?
Sep 06 06:15:53 <speachy> 2 bytes off.   buffer[22] through [26]
Sep 06 06:16:15 <wodz> I'll try to follow memset for this case
Sep 06 06:16:52 <wodz> speachy: Is there officia xduoo x3 update file available for download?
Sep 06 06:16:56 <speachy> It may be that memset() is similarly afflicted by the newer gcc wonkiness.
Sep 06 06:17:08 <wodz> speachy: unlikely it is in asm
Sep 06 06:17:55 <wodz> speachy: anyway, threading code was horribly broken and it was pure luck that old gcc generated correct code
Sep 06 06:18:10 <speachy> there supposedly is an update, but seems to be hard to obtain.
Sep 06 06:18:55 <speachy> vortex had a link to the stock 1.1 firmware
Sep 06 06:18:57 <speachy>!5o1hGJ5C!b59kvcCBcTIp_oAr35NZBMacRHnel-r542OBxM1B0t0
Sep 06 06:19:07 <wodz> speachy: The only thing I found is X3-BurnTool.rar which inside has X3 Firmware folder.
Sep 06 06:19:09 <speachy> haven't found the official download.
Sep 06 06:20:38 <wodz> speachy: I disassembled SPL1 part to better understand boot process. I know the parts but don't know where from it comes.
Sep 06 06:21:58 <speachy> familiar with arm and some x86 asm, but mips I need to work on a lot more still.
Sep 06 06:23:35 <wodz> mips is pretty easy. There are some quirks though like split address space, branch delay slot and weird coprocessor 0 interface.
Sep 06 06:24:16 <speachy> yeah, mainly just a matter of sitting down with a proper reference and walking through something.
Sep 06 06:24:55 <speachy> C is my preferred high-level assembler.  :P
Sep 06 06:27:43 <wodz> speachy: ok, The 1.1 firmware from link you provided is the same as in X3-BurnTool
Sep 06 06:28:30 <speachy> doesn't help that the ingenic xburst extensions aren't publicly documented
Sep 06 06:28:31 <wodz> speachy: Thats a pitty since SPL1 used in xvortex patched bootloader doesn't match this update.
Sep 06 06:29:32 <speachy> and no mainline binutils/gcc support either, just patches against relatively ancient releases.
Sep 06 06:30:03 <wodz> speachy: It is irritating but it is minor problem. Pamaury did quite some research on jz4760b and we know interesting parts (minus simd i
nstructions which we don't use anyway)
Sep 06 06:31:33 <speachy> would be nice to reconcile the core jz7460 stuff in Pamury's WIP Fiio X1 patches with the Xduoo X3 stuff.
Sep 06 06:32:10 <speachy> but that's another uphill slog.. and I'd really like to see the X3 working well first.
Sep 06 06:32:46 * wodz diving into memset()
Sep 06 06:33:17 <speachy> I'm going to go AFK for a bit.  gotta wake up the household.
Sep 06 06:33:33 <speachy> 0630 here
Sep 06 07:04:46 <speachy> gotta go.  will be back in a few hours.  (A shame the logbot is busted..)
Sep 06 07:30:15 <wodz> incredible, memset() is indeed f***ed on mips
Sep 06 09:19:58 <wodz> pamaury: ping
Sep 06 16:00:41 <wodz> speachy: ping
Sep 06 16:10:52 <speachy> I'm here, not for long though
Sep 06 16:15:24 <wodz> speachy: you can try changing line 224 of memset.S to SWLO a1, -1(a0)
Sep 06 16:16:42 <wodz> speachy: you also need to define SWLO as swl for little-endian
Sep 06 16:16:42 <speachy> from swhi to swlo?
Sep 06 16:16:55 <wodz> yeah
Sep 06 16:17:29 <speachy> unrecognized opcode
Sep 06 16:17:43 <speachy> memset.S:224: Error: unrecognized opcode `swlo $5,-1($4)'
Sep 06 16:18:24 <speachy> ah whoops
Sep 06 16:21:21 <speachy> looks like it's working
Sep 06 16:24:32 <speachy> gotta run.
Sep 06 16:24:37 <speachy> be back later
Sep 06 16:40:03 <wodz> gevaerts: who is responsible for logbot?
Sep 06 17:00:44 <wodz> gevaerts: or logbot could identify itself to NickServ
Sep 06 17:52:21 <scorche|sh> we have no more z
Sep 06 17:53:08 * gevaerts sets mode -z on #rockbox
Sep 06 17:53:13 <gevaerts> Oh, ok!
Sep 06 17:53:25 <scorche|sh> oh - i just tweaked the mlock
Sep 06 17:53:26 <scorche|sh> heh
Sep 06 17:57:32 <gevaerts> Hmmm, why can't I set mode -r?
Sep 06 17:58:36 <gevaerts> I'm probably just doing things wrong
Sep 06 17:59:20 * scorche|sh sets mode -r on #rockbox
Sep 06 17:59:37 <scorche|sh> r was still mlocked in
Sep 06 18:00:17 <gevaerts> Right!
Sep 06 18:00:38 <gevaerts> Hmmm
Sep 06 18:03:27 * gevaerts removes quiet on $~a
Sep 06 18:03:39 * gevaerts sets quiet on $~a
Sep 06 18:03:49 <scorche|sh> :)
Sep 06 18:04:02 <gevaerts> I'm just hoping I'm doing this right!
Sep 06 18:04:31 * gevaerts removes quiet on *!
Sep 06 18:04:40 <gevaerts> Hmmm
Sep 06 18:04:46 <gevaerts> How do you do exceptions?
Sep 06 18:05:26 <gevaerts> And do we need to keep the +q for those age-old things around?
Sep 06 18:06:11 <gevaerts> Ah
Sep 06 18:06:11 <scorche|sh> exceptions are +e
Sep 06 18:07:32 <gevaerts> scorche|sh: is that a plausible pattern?
Sep 06 18:07:39 * gevaerts wants to make sure!
Sep 06 18:07:54 <scorche|sh> i can't recall what logbot's hostmask was, but sure
Sep 06 18:08:19 <gevaerts> I based it on what /whois told me, so those bits should be ok
Sep 06 18:08:20 <scorche|sh> you could also do something like logbot!*@*
Sep 06 18:08:32 <scorche|sh> whatever you need to do.  :)
Sep 06 18:08:50 <gevaerts> Let's just do it. Can't harm
Sep 06 18:09:03 <scorche|sh> well, it is a bit unnecessary, but sure.  :)
Sep 06 18:09:38 <scorche|sh> nick!identorusernameonhost@host
Sep 06 18:10:19 <scorche|sh> oh, hey - i did a little write up ages ago:
Sep 06 18:10:19 <gevaerts> Does the ~ at the start of what /whois shows (was that registration status?) matter?
Sep 06 18:11:11 <scorche|sh> the tilde means they aren't running identd and the username on the host is used
Sep 06 18:12:03 <gevaerts> ok, it works
Sep 06 18:13:37 * gevaerts has changed the topic to: You need to be registered to be able to speak: see for details
| Rockbox 3.14 released! | Please read before speaking: | Please stay! You may need to wait some time to get your answ
er, DON'T leave after a few minutes because you think nobody is there! | If you can't stay and wait, please post your quest
Sep 06 18:14:02 <scorche|sh> you technically don't need to op up to change the topic, but that works too
Sep 06 18:14:33 <scorche|sh> also, your topic got cut off
Sep 06 18:14:36 <gevaerts> I don't do these things often enough
Sep 06 18:15:08 <scorche|sh> TOPICLEN=390
Sep 06 18:15:13 <scorche|sh> max: ^^
Sep 06 18:15:20 * gevaerts is trying to trim it
Sep 06 18:16:32 <gevaerts> Probably!
Sep 06 18:17:02 * gevaerts has changed the topic to: You need to be registered to be able to speak: see for details
| Rockbox 3.14 released! | Please read before speaking: | Please wait some time for an answer, DON'T leave after a few
 minutes! If you can't wait, post your question to the mailing list | This channel is logged at
Sep 06 18:17:15 <gevaerts> Yay!
Sep 06 18:20:54 <scorche|sh> yup
Sep 06 18:20:59 <scorche|sh> what do you want it to be?
Sep 06 18:21:14 <scorche|sh> i mean, it shouldn't just be a copy of the topic
Sep 06 18:21:14 <gevaerts> I'd just add "You need to be registered to be able to speak: see for details" to that
Sep 06 18:21:51 <gevaerts> *maybe* with a mention of spam as the reason, but then people don't read and that makes it longer
Sep 06 18:25:29 <scorche|sh> done
Sep 06 18:25:53 <gevaerts> Thanks!
Sep 06 18:26:17 <gevaerts> Should be a bit friendlier than just refusing joins
Sep 06 18:26:54 <gevaerts> Now let's hope logbot finds its way back. If not, I'll try to poke zagor tomorrow
Sep 07 02:16:12 <_Bilgus> wodz I have a user that is unable to use lua on 3.14 or the current head what would align 4 have to do with a plugin failing? https:// when I change it to QWORD alignment it seems to work I'm t
hinking its a coincidence ATM
Sep 07 02:18:01 <wodz> _Bilgus: I'd need to study this a bit longer but this seems strange as next section is cache line alligned
Sep 07 02:20:30 <_Bilgus> I can affect a similar result by adding a few items to structs as well and I'm throughly confused as to why
Sep 07 03:51:04 <wodz> I really can't imagine how mips memset() bug went uncaught for sooo long.
Sep 07 04:47:01 <gevaerts> mips is the least used architecture I think
Sep 07 04:47:11 <gevaerts> And maybe asm was disabled for a long time? Not sure
Sep 07 04:56:19 <wodz> gevaerts: I am almost sure the bug is there from the day 1.
Sep 07 05:15:51 <wodz> hmm, current glibc implementation of memset() is much nicer then ours
Sep 07 08:49:31 <wodz> speachy: I commited memset() fix as well as mips threading fix. Could you test this?
Sep 07 08:52:45 <speachy> Will do once I get caught up with $dayjob's inbox.
Title: Re: Are the Rockbox IRC Logs broken?
Post by: RufusA on September 07, 2018, 10:39:19 AM
Thanks @Bilgus that explains it, I did notice all the spam bots hitting it last month.

Also thanks for the history, some catch up reading for me.

Guess I'm going to have to register with Freenode now if I want to carry on lurking!