Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: johanngomesb on August 03, 2013, 08:46:21 AM

Title: No partition found, plug USB cable (Sansa Clip +)
Post by: johanngomesb on August 03, 2013, 08:46:21 AM
When i start Rockbox, it says in the player:

"No partition found, plug USB cable"

When i start the original Sansa Firmware (LEFT + Power), it says in the player screen:

"FAT is corrupted, please connect to PC and..." (the rest of the message cannot be read)

When i plug the player in PC (Windows) and try to format the player, it says it cannot be formatted, when i try to access it says 'Insert a disk in the unit...", it looks like the contents cannot be accessed, neither formatted.

Linux (Ubuntu) failed to format it too.

What to do?  :-[

Thanks in advance, people
Title: Re: No partition found, plug USB cable (Sansa Clip +)
Post by: aargl on October 18, 2017, 06:12:49 AM
Hi all!
I'm answering this old topic because I'm quite sure it might help someone having the same issue. ;)

First, the reason for the issue: my Sansa Clip+ has become to disconnect from the computer, or having difficulties to connect, more and more, ending with the same messages as johanngomesb.
I firstly suspected Rockbox 3.14 or the Firmware update I made recently (clipplus01.02.18), but in the end it's clear it's a loose physical connection due to the age of the connector itself.  :(

Now the cure: I connected to Windows XP and had the same result as johanngomesb, "can't be formatted"!
As a last resort, I connected to my Mac (OS 10.9.5) and launched Disk Utility, the Sansa Clip was recognized!
I formatted to FAT, renamed it SANSA CLIPP in the Finder (for RockboxUtility to recognize it), reinstalled the bootloader with RockboxUtility, restored the last backup I made.
Then it needs to be rebooted on the original Firmware (LEFT + Power) to finish install. Switch it off when done, reboot on Rockbox, it might complain that no playlist was found but this message will disappear once you feed the Clip with music.

Now everything goes fine but I'm very careful when connecting the Clip, making sure the cable is stable (blocking it with some weight) and the Clip put with the face down (I suppose the position will vary depending on how the connector is worn-out...)
I ALWAYS connect AFTER booting on the original Firmware — although Rockbox 3.14 is supposed to work directly but that never worked correctly for me before the issue, so I stick with this safe procedure...  ;)

I suppose that when you can't format it neither on Windows, Linux or MacOS, the only option is a PC low level format utility but I hope I'll never have to try that...  8)