Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: Seufari on March 06, 2006, 08:02:13 PM

Title: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 08:02:13 PM
Something went wrong...

I uninstalled Rockbox (which was working great) using the method described on here and now my 60gb 5th gen  ipod is in an endless cycle of booting up and reseting...

I tried to reinstall rockbox but the ipodpatcher doesnt recognize any of the numbers as an ipod. 

I have a service plan at best buy, but I have an invisible shield and would much rather fix this myself. I am leaving for spring break saturday and probably wouldnt get the invisible shield replacement in time.

If anyone has any ideas give me a shout. I can get my hands on a fresh ipod if i need to extract the firmware or something. 

Any and all help is appreciated.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: fuzzyhair on March 06, 2006, 08:15:21 PM
I remember reading how to fix this on the ipod port section of rockbox. Go check that out.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 08:26:37 PM
What exactly did you do to uninstall rockbox?

Did you restore the original bootpartition.bin using ipod_fw, or did you just remove rockbox.ipod and the .rockbox folder?
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 08:44:46 PM
http://www.rockbox.org/twiki/bin/view/Main/IpodInstallation

I followed the directions there... I must have done something a little bit wrong when installing i guess?!?

I found the key combo to do a hard reset into disk mode (menu and action to reset then menu and play to enter disk mode)

Should I use the good ipod and remake the bootloader and everything?  How should I proceed?  I think its safe to say that the bootloader (or whatever) I currently have is corrupt.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 08:48:20 PM
Well, out of curiosity, why were you uninstalling it? I mean, you've just asked me how to reinstall it, so it seems odd that you *were* removing it.

Anyway, extract a clean bootpartition.bin from the working iPod, since you've got one at hand.

Then, if you don't want rockbox, use ipodpatcher -w N bootpartition.bin where N is the right number for the drive. If you do want rockbox, just use the clean bootpartition.bin to create a bootloader, and install it like normal.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 08:55:49 PM
lol... it probably wasnt the brightest idea... I was uninstalling because I was couldnt load the apple firmware, and then Itunes suddenly quit recognizing the ipod. I was going to reinstall the latest build 

I was really freakin out about 20 minutes ago, but now, it seems I am in the clear.

I really appreciate everyones help.  Hopefully I'll get her working again.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 09:01:37 PM
You never need to uninstall the bootloader.

If you delete rockbox.ipod, your ipod should from then on automatically go into the apple software, and work as it did before. It will still show rockbox briefly while turning on, but other than that you won't be in it.

To upgrade, you just need to unzip the newest rockbox.zip and put the new rockbox.ipod and .rockbox folder on your player.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 09:19:14 PM
well I got rockbox back on, but I am still having the same trouble booting to the original firmware.

I hold the menu button and it says "loading original firmware" but then it resets and loads rockbox...

Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 09:40:13 PM
That's very strange. What sort of iPod are you using?
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 09:43:43 PM
Im using a 5th gen 60gb video...
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 10:05:47 PM
Could you type exactly what line you used to create the rockboot.bin? (the last one you did with the ipod_fw command.)

Type it please, don't just copy and paste it from the page. I'm curious if maybe you're making a typo, or reading it slightly off (for example, -l instead of -i)
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 11:08:01 PM
well, i installed rockbox on the good ipod (white)and it is working as it should. 

anyways, I am typing...

ipod_fw -g video -o rockboot.bin -i apple_os.bin bootloader-video.bin

After I install the bootloader to the black ipod that has been giving me trouble  and I go to test it without the rockbox folder and files, it loads the bootloader but loops back around after a reset.  never loading the original firmware.

I think I am just going to restore the ipod and start over.  I am grateful I was able to force it into disk mode. 
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Llorean on March 06, 2006, 11:10:26 PM
Assuming both ipods are exactly the same model, you *should* be able to do
ipodpatcher -r N bootpartition.bin
to the one that's working, then
ipodpatcher -w N bootpartition.bin
(using the bootpartition you got from the working one)
and the other one *should* work. DO NOT patch this bootpartition. Since you're extracting it from one with rockbox installed, everything should already be there.
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 06, 2006, 11:11:27 PM
Assuming both ipods are exactly the same model, you *should* be able to do
ipodpatcher -r N bootpartition.bin
to the one that's working, then
ipodpatcher -w N bootpartition.bin
(using the bootpartition you got from the working one)
and the other one *should* work. DO NOT patch this bootpartition. Since you're extracting it from one with rockbox installed, everything should already be there.

I'll give that a shot....
Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: linuxstb on March 07, 2006, 04:38:49 AM
After I install the bootloader to the black ipod that has been giving me trouble  and I go to test it without the rockbox folder and files, it loads the bootloader but loops back around after a reset.  never loading the original firmware.

It sounds like something went wrong when you were extracting the apple_os.bin and apple_sw_5g_rcsc.bin files from your original bootpartition.bin

The file sizes (in bytes) for those three files should be something like the following (but my be slightly different depending on your firmware version):

apple_os.bin -  5879344
apple_sw_5g_rcsc.bin - 5243392
bootpartition.bin - 82220544

Title: Re: Uninstal Gone Wrong!!! Help!!!
Post by: Seufari on March 08, 2006, 12:26:58 PM
Thanks for all of the help...

I just went into disk mode and restored the ipod and started over.  Took a LONG time to transfer all of the stuff back over but its working great now!

Again, thanks for the help...