Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: e5xn1 on July 23, 2011, 08:29:42 AM

Title: [SOLVED] Stuck with installation on iPod Video (30GB)
Post by: e5xn1 on July 23, 2011, 08:29:42 AM

I just got an iPod Video and installed the stable Rockbox release (3.9) on it (using Rockbox Utility). It worked fine for one day and now keeps telling me, that I should use iTunes to restore it.

Here's what I tried so far:
- Diagnostics using the built-in diagnostic tool: Everthing's fine.
- Disk mode: The iPod does show up under Linux
- Reinstalling Rockbox: Trying both ways: manual and automated
-- Both ways tell me, that everything went fine, but the iPod keeps booting into that restore-screen
- Manual restore as described in the wiki
- Wiping the complete harddrive and recreating the filesystems

What did not work:
- Restoring via iTunes: I only have Win7 via VirtualBox. iTunes doesn't do anything when I pass the iPod through to the VM. The iTunes diagnostics tell me that everything's fine, except that I don't have an iPod/iPhone/iPad...
- Start the OF by keeping the hold-button engaged (worked only once...)

I'm using Arch Linux and Ubuntu here and have Win7 available via VirtualBox as mentioned above. If you need any further information to help, just let me know.
And yes, I did search the forums/wiki/FAQ before, but none of the mentioned solutions did work for me up to now.

Thanks in advance!


EDIT: I fixed it myself. I got the right OF at gnupod (0), restored the whole device and installed Rockbox again. It works, but messed around with my filesystem a lot. fsck.vfat is trying to fix this now as well...

(0): (