Rockbox Technical Forums

Support and General Use => Theming and Appearance Customization => Topic started by: HornetMaX on April 11, 2011, 01:42:41 PM

Title: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: HornetMaX on April 11, 2011, 01:42:41 PM
Hi all,
I've just discovered Rockbox (on a Sansa Clip+) and I love it.
Playing around with themes, I've found a few quirks:

1. Tags %bu (detect USB ?) and %tr (FM signal strength) are not documented on the Wiki page (http://www.rockbox.org/wiki/CustomWPS (http://www.rockbox.org/wiki/CustomWPS)).

2. The %Rm tag is supposed to return TRUE is rec mode is set to MONO, false if STEREO (as documented on the Wiki page). However in my tests it seems to be the other way around.

3. The %Ti tag (0,1,...,N indicating the FM preset) seems to work in the FMS but not in the SBS.
The numerical value does not get updated in the SBS, while it is updated in the FMS.

To show the two bugs, I add here a theme containing the minimal example of the two bugs.
[Note that I cannot attach a .fms and a .sbs :( I quote them below]

Install it, activate it and then:

- (assuming you have some presets) go in FM screen, scan mode, move from one preset to the other (left/right arrow): you'll see the number in the status bar (top) does not change, while the one in the middle of the screen it changes correctly

- go to Recording, in the status bar you have an "MO" for mono, "ST" for stereo, but you'll see they are swapped with respect to the actual setting.

MaX.

bugs.fms:
Code: [Select]
### Enable status bar.
%we

# Enable viewports.
%Vd(a)

# FMS - Preset.
%Vl(a,0,50,13,8,0)
%ac%?Ti<%Ti|??>

bugs.sbs:
Code: [Select]
# UI area viewport.
%Vi(-,0,8,-,-,1)

# Enable viewports.
%?cs<%Vd(a)%Vd(b)|%Vd(a)%Vd(b)|%Vd(b)|%Vd(a)|>

# FMS - Preset.
%Vl(a,0,0,13,8,0)
%ac%?Ti<%Ti|??>

# Rec - Channels.
%Vl(b,70,0,-,8,0)
%?Rp<%?Rm<MO|ST>>

Title: Re: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: Llorean on April 11, 2011, 02:56:14 PM
Being a wiki, you can add the missing tags to the wiki page.
Title: Re: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: HornetMaX on April 11, 2011, 03:30:55 PM
Being a wiki, you can add the missing tags to the wiki page.
Yeah, but having been playing with rockbox for only 3-4 days, I'm not very confident in my findings :)
If anybody can confirm, I'd be glad to add the missing tags to the wiki.

MaX.
Title: Re: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: Llorean on April 11, 2011, 03:45:00 PM
Confirm what, exactly?
Title: Re: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: HornetMaX on April 11, 2011, 04:25:40 PM
Confirm what, exactly?
The usb tag,  it does what exactly ?
I've never been able to trigger it, I can only speculate it's there for future improvements (e.g. rockbox handling usb transfer in MSC).

The signal strength, what's the number it returns ? It the SnR in dB ?

MaX.
Title: Re: 2 possible bugs [Sansa Clip+, Rockbox 3.8.1]
Post by: AlexP on April 24, 2011, 06:44:54 AM
http://download.rockbox.org/daily/manual/rockbox-sansaclipplus/rockbox-buildap2.html#x17-358000B.21

Recording tags seem to be missing from the manual, I'l try to add them soon.