Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: gbl08ma on February 04, 2011, 01:49:20 PM

Title: (lack of attention) Where did the track rating feature go, in the last days?
Post by: gbl08ma on February 04, 2011, 01:49:20 PM
EDIT: This is now solved, don't bother with this.

I know that Rockbox used to have a track rating function, which allows tracks to be rated in a scale from 0 to 10. The tracks were rated while they are playing, by opening the context menu at the WPS and selecting "Set Song Rating". The rating was then stored in the databse, I think, and some themes (as photoSkins) would display them using the theme tag for it.

Now comes the strange part... some days ago (I noticed it yesterday, but it could be that way since, at a maximum, four days), I was going to rate a song I was listening to. I hold select, the context menu opens and... the option for rating is not there! The first thing I thought was "Damn! Again, something I changed in the code broke this and I don't know how ti fix it.", because I was using my custom build.

Today, which is when I'm having time, I updated my code from SVN, built my custom build, updated the Rockbox on the player... and nope, the option wasn't there. I thought it was, for example, tagcache not defined on /firmware/export/config.h or on the /firmware/export/config/ipodnano2g.h files, but a quick Find told me they were still defined.

So, I downloaded the latest official build r29205, installed... when I go to the WPS to rate a song... the option is still not there! In the official build! Even more strange, I looked in the onplay.c file and the menuitem declaration for the rating menu item is still there.

By the way, in the database the option for browsing for User Rating is still there, although all my music, even those I had already classified, are with a rating of 0. It seems something broke the ratings part, not only the menu item, but also something else, because Rockbox is setting every file with a rating of 0.

It would be good if someone looked further into this bug... I don't post a bug report, because I'm not sure this is a bug (who knows, you could be removing the rating feature!). I wonder if it's only on my player (iPod Nano 2nd Gen), or if it's common to everyone. If it was only on my custom builds, I wouldn't bother asking for help, but as this happens on the official one...
Title: Re: Where did the track rating feature go, in the last days?
Post by: evilnick on February 04, 2011, 02:39:55 PM
Have another read of the manual, section 4.2.3
Title: Re: Where did the track rating feature go, in the last days?
Post by: gbl08ma on February 04, 2011, 04:03:22 PM
But I had Gather Runtime Data enabled... *thinks twice* oh, well, I accidentally cleared the settings four days ago by turning on hold on startup. The settings were reverted to the defaults, I restored them as far as I recalled correctly, but forgot about Gather Runtime Data.
Thanks for pointing this out. How stupid I am!  :-[

Even further, in my opinion the problem didn't reside on the database, but on the code of menus of the WPS... this is the result of not thinking out of the box.

Even that way, although the rating option still appears, the menu of the WPS still seems reordered... perhaps it's just me.