Rockbox Technical Forums

Support and General Use => User Interface and Voice => Topic started by: wp2 on June 10, 2010, 01:32:34 PM

Title: sansa clip +
Post by: wp2 on June 10, 2010, 01:32:34 PM
A week ago the 'home button' would take me back to the original firmware settings.  By pressing home for 2 seconds or so it would revert back to before rockbox which was really handy for my partner who prefers the sansa system.  For some reason now when I press the home button a screen prompts me to choose between 'supported files' 'all files' etc.

I can't find anywhere on the player to bring this feature back of reverting to the old settings.
?
Title: Re: sansa clip +
Post by: Vague Rant on June 10, 2010, 01:40:40 PM
I don't believe the Clip+ (or any other device) has ever had that functionality in Rockbox, however booting up the Clip+ with either Left ("rewind") or Home held down will boot the original firmware.

Also, if you have the latest bootloader, plugging the Clip+ into USB will boot the OF, however this will eventually not be the case, once USB transfers are supported in Rockbox, and so shouldn't be relied on indefinitely.
Title: Re: sansa clip +
Post by: wp2 on June 10, 2010, 03:35:24 PM
pressing home worked while booting
..thank you for your reply

having worked before during normal use might have been a glitch that weeded itself out when I did a theme change


Title: Re: sansa clip +
Post by: Chronon on June 10, 2010, 04:31:08 PM
Possibly.  It sounds like a crash leading to the bootloader booting SanDisk's firmware because you were still holding Home.