Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: jwp1 on October 26, 2009, 10:47:17 AM

Title: H10 Red with MTP 3.4 install
Post by: jwp1 on October 26, 2009, 10:47:17 AM
Hi I had been running the old Rockbox for a long time.
Enjoyed greatly and used it almost everyday.
I had heard that there was a new and wanted to review it for my podcast.

I have the MTP H10 and it is Red in Color just like the example one.

I did the upgrade utility and I did a click error and reinstalled the boot loader.

The Iriver will not boot now.

It still acts as a disk when I press the button the restore does not work either.

I looked on the website for the old boot loader and could not find it.

I really want the Rock Box to work again but I am not sure how to move forward.

I read the pdf and renamed the file and placed in the right spot.
I also ran the upgrade utility from three different OSs and the result was still the same.

Kind Regards

Title: Re: H10 Red with MTP 3.4 install
Post by: jwp1 on November 03, 2009, 07:05:28 PM
Again pretty much my fault.
I used the install program instead of doing it by hand and miss clicked.

I ran all over the place and the tool you need is the Iriver firmware updater.  (I have this so just send me a note and I will email it to you).  Then you have to get their firm ware version.  (I would get the firm ware to because it might be there in a few more months.

It will not run in whine or vista only on XP.  (It did start but had errors in everything.)
It made me reformat everything.
It installed the factory provided firm ware

Then I went to the 3.4 rockbox manual and extracted the 3.4 zip file into the root.  Then I downloaded the H10.mi4.
Then renamed the original file a common name.

copied my music and book marks back.
Then had to make all the folders visible.

Then it worked like it did with my prior rockbox.