Rockbox Technical Forums

Installation / Removal => Manual Installation => Sandisk - Installation/Removal => Topic started by: charon79m on June 04, 2009, 10:11:50 PM

Title: Sansa e280 "No Sansa Detected"
Post by: charon79m on June 04, 2009, 10:11:50 PM
I am attempting to install on a referb Sansa e280 v1  (firmware 01.03.02A) under Ubuntu Linux 9.04.

I have set the USB mode to MSC.

When I connect the device is shows up as follows:

/dev/sdb1 on /media/SANSA VIEW type vfat (rw,nosuid,nodev,uhelper=hal,shortname=mixed,uid=1000,utf8,umask=077,flush)

Here are the permissions on the mount point:

drwx------ 10 mknisely root 4096 1969-12-31 19:00 /media/SANSA VIEW/

When I run the automatic installation app (sudo ./rbutilqt) and give it my model and the mount point above and tell it to install, I receive back "No Sansa Detected."

I have remounted /dev/sdb1 at /media/sansa as root and tried that too... there is no change.  Suggestions?

I'll be trying the install on a Windows box tomorrow, but I'd like to figure out why the Linux installer isn't working for me.

Next, I've tried the manual install.  I'm able to extract the directory to the e280 fine, but when I run sansapatcher I get the following output:

[INFO] Scanning disk devices...
[ERR]  No E200s or C200s found, aborting
[ERR]  Please connect your sansa and ensure it is in UMS mode
[ERR]  Please refer to the Rockbox manual if you continue to have problems.

I'd appreciate any suggestions.   Thanks.
Title: Re: Sansa e280 "No Sansa Detected"
Post by: Llorean on June 04, 2009, 10:15:47 PM
The Sansa View is NOT the e200. They're different players entirely.
Title: Re: Sansa e280 "No Sansa Detected"
Post by: charon79m on June 04, 2009, 10:24:16 PM
Well... that's no good...  Yet, it explains quit a bit. 

Thanks for opening my eyes to the obvious.