Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: sandia on December 07, 2004, 11:11:50 PM

Title: no sound
Post by: sandia on December 07, 2004, 11:11:50 PM
I have the 20GB Jukebox recorder with the latest version of Rockbox and recently no sound has been coming out of  the Recorder.

The hard disk seems OK and the files seem to be playing, but no sound is coming out. I have changed earphones, reset settings, upgraded Rockbox, and even went back to original Archos firmware with no luck.

Up until now, the unit had been working well for over a year. Any ideas? Thanks.
Title: Re: no sound
Post by: BrianWolven on December 08, 2004, 02:05:41 AM
A broken headphone jack, perhaps?
Title: Re: no sound
Post by: sandia on December 08, 2004, 05:03:49 AM
Possibly- but being a newbie ( :), I am wondering how to proceed from here. I rarely tinker with the guts of things, usually I just throw them away or forget about it.

But the Jukebox has really been working well and I figured someone on the Forum might possibly suggest a game plan, something similar to helping a passenger land an airplane after the pilot takes ill...

Title: Re: no sound
Post by: LinusN on December 08, 2004, 05:11:25 AM
Well, first of all, do you hear anything if you wiggle the earphone plug while inserted?
Title: Re: no sound
Post by: [IDC]Dragon on December 08, 2004, 11:32:18 AM
Sorry for asking the obvious:
- correct jack being used?
- volume up?
- "reset settings" tried?
- Archos firmware also silent?
- digital out working? (If you have something to connect there)

Title: Re: no sound
Post by: marianist on December 09, 2004, 12:38:36 AM
If you want to try a little disassembly Bjorn's post is great.     once you remove harddrive and lift off plastic protecter you can visualize the earphone jack with a magnifying lens and see if contacts looks bent or broken. Mine had a bent up center contact- if earplug pushes wrong it will smash this post down into receptacle. I bent this with opposite twist and it worked again.
Title: Re: no sound
Post by: sandia on December 09, 2004, 07:09:05 PM
Thanks for the advice!

I have tried all the obvious (correct jack, volume up, reset settings, etc). There is no distinct sound when I put in earphones- but there is the faintest flash of noise for a brief moment. When I put the original Jukebox firmware back on- the file seemsed to play, but it appeared that no sound was coming out of either channel. Is there any other hardware part besides the earphone jack that may be responsible and/or can be fixed?
Title: Re: no sound
Post by: LinusN on December 10, 2004, 04:58:33 AM
I have no idea what may be causing this. There aren't many components between the DAC and the earphones that can break. You will probably have to open it up and measure with an oscilloscope or something.
Title: Re: no sound
Post by: sandia on December 11, 2004, 09:55:36 AM
Thanks- I will open it up and take a look. If I can find the problem and get the unit working again, I will report back. If I can't find the problem, at least it will have been fun.

I will say that that the Rockbox firmware is really great and versatile- and it is easy to use (even for novices like me). Hopefully something will work out with this unit. If not, that's OK- I am already looking for another Jukebox.