Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: Bill Tuttle on December 24, 2008, 03:28:01 PM

Title: Error Compiling - Can't find rule for buildlogo.240x74x16.o?
Post by: Bill Tuttle on December 24, 2008, 03:28:01 PM
I've been building this for a while. Recently I've started getting this error. I've done an svn update. At revision 19582. I get the following error:

gmake: *** No rule to make target `/rockbox/build/apps/bitmaps/native/rockbox/buildlogo.240x74x16.o', needed by `/rockbox/build/rockbox.elf'.  Stop.

Sounds like maybe a missing image file?

   ---Bill
Title: Re: Error Compiling - Can't find rule for buildlogo.240x74x16.o?
Post by: saratoga on December 24, 2008, 04:30:08 PM
That usually means your build directory is screwed up.  Do a make clean and/or rerun configure and it'll probably fix itself.
Title: Re: Error Compiling - Can't find rule for buildlogo.240x74x16.o?
Post by: Bill Tuttle on December 24, 2008, 05:57:07 PM
Thanks but still getting the same result after make clean and configure...


UPDATE:

OK, i checked out the project into a new, empty directory, configured it and when I make it, I still get the same error. I'm building for a Gigabeat F40.
Title: Re: Error Compiling - Can't find rule for buildlogo.240x74x16.o?
Post by: Llorean on December 24, 2008, 07:00:16 PM
If it's not showing errors on our build servers you need to figure out what's different for you.
Title: Re: Error Compiling - Can't find rule for buildlogo.240x74x16.o?
Post by: Bill Tuttle on December 25, 2008, 11:47:23 PM
No idea at this point. Since it's a clean install. What is it trying to do? Build a logo image?