Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: Revenger on January 26, 2008, 02:48:26 AM

Title: main menu after song ends ipod button press
Post by: Revenger on January 26, 2008, 02:48:26 AM
After playing a list of songs on my ipod video 80gb and rockbox goes to the menu I noticed I have to press menu to be able to use the menu.

Would it be possible that on ipod releases that it automatically sends the menu button after the play list ends so when it goes back to the menu we don't have to press menu to be able to use the menu?
Title: Re: main menu after song ends ipod button press
Post by: MarcGuay on January 26, 2008, 10:44:10 AM
If I understand what you're saying correctly, you should file a bug report in the tracker.

If I don't understand, then I don't understand?
Title: Re: main menu after song ends ipod button press
Post by: markun on January 27, 2008, 07:18:19 AM
some responses from IRC:

11.59.14 #       this sounds like a strange bug (or I don't understand him) http://forums.rockbox.org/index.php?topic=15137.0
12.00.33 #       I bet he used hold during playback
12.01.46 #       The ipod clickwheel button driver has the problem that sometimes the first button press after releasing hold doesn't work
12.02.04 #       or he could have "First keypress enables backlight only" turned on. or something.
Title: Re: main menu after song ends ipod button press
Post by: Revenger on January 28, 2008, 01:10:04 AM
Seems its fine on the latest daily.

What it was doing is when going out of that now playing screen the click wheel wouldn't work until I pressed a button 'to gain control so to say'

Back light button press wasn't on or anything as i could change volume in the now playing screen fine.

Now I have some weird a bugs in the latest daily where

. I load up track 1 first file in the directory and rockbox track number saids 02/XX (all the time)
. loading the 2nd last track saids the 2nd last is the last track.(All the time)
. Loading the 2nd last track plays last track instead (rarely hapenging)
. loading up the last track just takes me back to the menu. (this is hapenging all the time)
. Total track time saids 00:00
. Total track time stays at XX:XX remaining and no progress bar and time changing.

All these 3 things happen randomly in any order.

Think I need to mby re-install rockbox.

With these latest bugs tried a clean rockbox daily folder on my ipod with no luck.

Video of it refusing to play last file in a folder http://guildwars.tyria.net/files/dump/rf.wmv