Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: locagent on May 23, 2007, 07:21:23 AM

Title: need help! cant get rockbox to load right
Post by: locagent on May 23, 2007, 07:21:23 AM
Ive have loader 2.5 installed on my 5.5g video ipod and I can load Ipodlinux and Apple OS, well I want to install rockbox on my ipod to but when I install it, it automatically loads rockbox so I thought well If i click the center and top button it will load into loader 2.5 so I can choose what I want to load like Apple OS, ipodlinux etc. well after that it still loads into rockbox. right now I have the Ipodlinux installed with loader 2.5 but my question is how do I install rockbox to where it will load on loader 2.5 first so I can choose to switch to apple OS, Ipodlinux and rockbox ???
Title: Re: need help! cant get rockbox to load right
Post by: AlexP on May 23, 2007, 07:25:23 AM
Loader 2.5 is not Rockbox software and as such unsupported.

Either have a look in this thread http://forums.rockbox.org/index.php?topic=9658.0 or ask the iPod linux people, or use the Rockbox bootloader
Title: Re: need help! cant get rockbox to load right
Post by: locagent on May 23, 2007, 05:04:02 PM
Is there any loader where you can choose to load apple OS rockbox and linux because I know other people who have done it but I dont know how they did it
Title: Re: need help! cant get rockbox to load right
Post by: bluebrother on May 23, 2007, 05:54:54 PM
The Rockbox bootloader can do this.

Install IPL and put the kernel into a file /linux.bin. Rockbox will load that file if you hold Play when booting while it loads AppleOS when you enable the hold switch while booting.

You won't have a nice gui in that case.