Rockbox Technical Forums

Support and General Use => Theming and Appearance Customization => Topic started by: mschneider on May 22, 2007, 05:04:20 PM

Title: Album Art builds- patched?!
Post by: mschneider on May 22, 2007, 05:04:20 PM
I've patched a few album art builds myself and downloaded a couple others. When i put these into the sansa e200 simulator and apply an album art theme the default wps is shown instead of the album art wps. Did i do something wrong patching?
Title: Re: Album Art builds- patched?!
Post by: elborak on May 22, 2007, 05:25:33 PM
Likely the .wps files you are using have syntax errors in their tags. Try the --debugwps switch to the simulator.
Title: Re: Album Art builds- patched?!
Post by: Llorean on May 22, 2007, 05:32:38 PM
You can't put a build into the simulator. You have to compile the simulator with the patch. The simulator IS the build.
Title: Re: Album Art builds- patched?!
Post by: mschneider on May 22, 2007, 05:42:04 PM
To compile the simulator with the patch would we first patch the file as a normal build and then re-configure as a sim and zip?
Title: Re: Album Art builds- patched?!
Post by: Llorean on May 22, 2007, 05:43:05 PM
You don't need to make a normal build. Just patch the source code, run configure, choose a simulator, make, and make install.
Title: Re: Album Art builds- patched?!
Post by: elborak on May 22, 2007, 05:44:09 PM
Why would you need to zip? Create a build directory for the version of the sim you want to build (using the same patched sources as you plan to use for your ultimate target), configure, build, install, run.
Title: Re: Album Art builds- patched?!
Post by: Llorean on May 22, 2007, 05:46:21 PM
Sorry, I meant to type "make install". It's been a long day.