Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: cheesecake on November 23, 2007, 06:46:37 AM

Title: Problems with Samba
Post by: cheesecake on November 23, 2007, 06:46:37 AM
This might be n00bish, but no matter what i do, i can't get samba running, and even if i could, i haven't been able to find anything in either the forums or the wiki to help. This could just be me, but i've seen a lot of problems with it before.
For the record I have tried (with vmware running):
In Start > Run typed "\\debian\user" but "the network address was not found"
Also tried this in internet explorer, and windows explorer.
Looked in My Network Places, but the only things there were VMware1 and VMware8, along with my normal internet connection (note: the VMware1 and 8 might not be spelled correctly, but the name is used to indicate something from vmware is running. Also, the numbers are correct.)
I tried resetting vmware, but none of the solutions i found worked under either root or user.
Help please???
Title: Re: Problems with Samba
Post by: bascule on November 23, 2007, 09:03:18 AM
Although I said that thread I linked to might help you, it didn't actually help me at the time. I had exactly the same symptoms and none of the suggestions helped.

Although it's not a very satisfactory answer, if I were you, I would re-install a fresh copy of VMWare and the Rockbox image and try again. That was the only way I could get it to work... :(

You must have the Rockbox image actually running in VMWare.
There is no need to 'start' Samba, as it runs automatically within the Rockbox image
Title: Re: Problems with Samba
Post by: GodEater on November 23, 2007, 09:16:03 AM
I seem to recall that most of the issues we get around this are to do with the way the networking is setup by the VMWare Player.

IIRC, NAT and Bridged don't work, and you have to use whatever the third option is (I fail to recall it's name).
Title: Re: Problems with Samba
Post by: Llorean on November 23, 2007, 01:22:22 PM
The problem I encountered was with VMWare set to resume, as opposed to powering down and back up. Any time I forced it to fully power down the VM, the next time I used it, the networking would work. If I just let it suspend, the samba share wouldn't be available next time I ran it.
Title: Re: Problems with Samba
Post by: cheesecake on November 23, 2007, 03:18:52 PM
Okay.
Well, i set the ethernet to host-only, and looked in my home directory (while the image was running), and there was nothing there.
I also tried start > run, but that didn't do anything.
I did this as both root and user (even though my files are under user), as well as with and without a shell running, each time restarting in between.
Are there any other ways to use samba???

Also, I can get my mp3 player mounted in vmware. Is it possible to copy the file from the image to there???
Title: Re: Problems with Samba
Post by: speedebikes on November 23, 2007, 08:59:06 PM
Cheesecake,

As stated before, the rockbox vmware image is already configured for networking with Samba.  All you need to do is to connect to it from the windows end.

From Windows, open "My Computer"  or an explorer file browser window.  Then in the menu click "tools/Map Network Drive..."

Where it says 'Drive:'
Pick a drive letter - preferably fairly high up alphabetically to avoid conflicts with the automapped letters when attaching additional devices like your mp3 player.  I chose 'R' for rockbox...

Where it says 'Folder:'
enter "//debian/user"

You probably want to have the 'Reconnect at logon" checkbox checked.

When you get prompted for a signon enter "root" with a password of "rockbox".

Now you should have access to the your files from windows through the new drive "R:" or whatever you chose to have mapped.

btw, all of the above will only work if you have enabled windows networking.  You can do that through the 'control panel' if you haven't done it already, although it's a bit more complicated and I have it done it recently to be up for giving you detailed instructions here.


Todd Allen
Title: Re: Problems with Samba
Post by: cheesecake on November 24, 2007, 08:28:25 AM
First, this is genius.
Second, it doesn't work currently because
Third, I'm not sure windows networking is set up, and even if I did, I can't find what you are talking about under control panel.
Is it at all possible to navigate me to this???
Title: Re: Problems with Samba
Post by: speedebikes on November 25, 2007, 11:00:34 AM
Cheesecake,

Setting up windows networking varies a bit in different versions of Windows.  I'm running XP and under the 'Control Panel' are entries for the 'Network Setup Wizard' and 'Network Connections'.

I'd check 'Network Connections' first.  You ought to have an entry for a "VMWare Network Adapter".  On my system it was created automatically after running VMWare.

If you don't see this, you might need to run the network setup wizard or perhaps the new connection wizard.  For help with these, try using 'Google' or your favorite websearch on strings like "help network setup wizard" which ought to get you to the Microsoft docs.

If you see the "VMWare Network Adapter" you ought to be able to see under 'My Network Places' a folder 'Workgroup/Debian" under which you should see your rockbox filesystem.  The 'Map Network Drive" that I told you about previously lets you make a convenient way to access this through a new drive letter.  Previously I said to make the mapping with the 'root' signon, although I should have told you to use the 'user' signon for making a mapping into the user filespace.  Use root if you want to make a mapping into the root of the filespace to modify the linux system files.  Both 'root' and 'user' have the password 'rockbox'.
Title: Re: Problems with Samba
Post by: cheesecake on November 25, 2007, 04:05:57 PM
Okay, i think i finally understand what the problem is.
I can't view workgroup computers. I have admin, but for some reason, it returns an error.
Could this be a problem???
Title: Re: Problems with Samba
Post by: speedebikes on November 25, 2007, 11:29:12 PM
Are you saying you don't have a Workgroup folder under 'My Network Places' or are you saying it's empty?
Title: Re: Problems with Samba
Post by: cheesecake on November 26, 2007, 06:44:41 AM
I have an icon in the explorer bar to the left that says: View Workgroup Computers
Or something to the same effect.
When I click on it, it starts going, I wait a minute or two, then I get an error message, and it doesn't show me the quote-unquote workgroup computers.

Sorry for any lack of clarity in my previous post.

Edit: The error message is: "The list of servers is unavailable."

Also, I already have admin. And there is no "Workgroup" folder.

Edit Again:
After all this time, it was the computer. I tried on another one, and was able to get in with no trouble. Still, thanks to everyone who tried to help, you guys were amazing!!!
Title: Re: Problems with Samba
Post by: shotofadds on December 19, 2007, 04:21:34 AM
Sometimes if you pause the VM (rather than fully reboot it each time) I find samba simply doesn't re-start properly. You can force the server to restart by typing:

su
/etc/init.d/samba restart

Works for me.