Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: tigertom2003uk on November 06, 2008, 04:02:10 PM

Title: Rockbox not booting on my H120
Post by: tigertom2003uk on November 06, 2008, 04:02:10 PM
Hi everyone,
I have just fixed a H120 which I bought from eBay a few months ago & it seems to work fine now until I tried to install Rockbox onto it!
The problem is that as soon as the player starts to try & load Rockbox from the hdd it comes up with: ATA ERROR -42, PRESS ON TO DEBUG, then all I get is 13 lines of moving txt & numbers & I can't turn the player off, I have to press the reset button it get it to go off.
As soon as I try to get it to load again it does the same thing but only stays on for about 30 seconds & then turns itself off.
I have tried to boot in the iRiver firmware while Rockbox is still on the drive & that works fine, but as soon as I remove Rockbox from the drive & turn it off & back on again, all I get is the bootloader & then the iRiver splash & the iRiver firmware boots up.
I have tried it with the 1.66EU & 1.66K & 1.65E original firmware but still get the same problem!
I have also tried to flash the player with each original firmware first before I patched the firmware for the bootloader on all the above firmwares, still same problem!
I have also tried a diffirent drive in the player & still it does the same thing.
The bootloader works fine & the begining of the Rockbox boot starts up ok, saying: Rockbox loading, but after that I neither get the ATA ERROR -42 or just the lines of txt & numbers.
The only thing I can think of either that the flash memory is faulty or may be that I have a US player?
So does anyone out there know what could be the problem?