Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: netflixvimeo on September 20, 2021, 10:30:48 AM

Title: I think I screwed up.
Post by: netflixvimeo on September 20, 2021, 10:30:48 AM
Hi there,

I tried installing rockbox on my ipod classic 120 GB black (which was modded to a bigger battery and 256 gb) and for some reason it didn't install. Anyway, I thought I could get itunes to restore it but it doesn't even recognize the device anymore.

Here's the kicker, my hold button is broken so I couldn't even get into the default ipod bootloader. Now I am stock on Rockbox Bootloader ver 1.0 and it says "no partition found".
"Entering USB mode.."
"Bootloader USB mode"

I can't fix an ipod classic in my country. I went to loads of iphone repair shops and they couldn't even do it as they didnt have any parts for it. I think in a developing nation so basically I'm screwed.

Is there anyway I can get itunes to restore the ipod? I'm on windows btw
Title: Re: I think I screwed up.
Post by: frostknight on October 04, 2021, 03:35:12 PM
I had a similar problem with my sansa mp3 players,

IF and ONLY IF you can connect to the STORAGE on it, and add a bin of the FIRMWARE can this be fixed, if not... idk...

I recommend trying to plug it into your computer and put whatever firmware bin you would use to flash it inside the mp3 player storage...

By that, I mean the one the rockbox requires before it can be installed. ;)

That worked for me with sansa clip+ sansa fuze+, it all depends if your computer even detects it.  I know on my linux OS it worked easily. Only thing is, I don't know if this will work on windows 10 or 11, so your results may vary.

Small  note,   I am an intermediate user of linux,  I have installed arch based systems and debian based systems...  That aside, though I can't give you much more info than that regarding a fix. I know very little about how to fix hardware problems aka, via flashing externally.  If your storage is shot, GG... :(

I wish you the best on this, hope it works!
Title: Re: I think I screwed up.
Post by: K4sum1 on October 06, 2021, 05:05:09 PM
You need to put the iPod into hold, then plug it in to restore old firmware.