Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: Renderking on September 08, 2013, 04:51:55 AM

Title: sh-elf-gcc: not found
Post by: Renderking on September 08, 2013, 04:51:55 AM

I have an Archos Recorder (V1) and try to install a 256 GB SSD.
Unfortunately its not working, even I follow all the instructions here to the spot.
Trying to use the provided build there, but the second partition is never showing up as <HD1> like it's described there.
So now I try to make my own build and again follow all the instructions of the development guide using the VirtualBox image.
But when I run the ../tools/configure I get this after selecting "Normal" :

Code: [Select]
Normal build selected
Using source code root directory: /home/ubuntu/rockbox
../tools/configure: 1: ../tools/configure: sh-elf-gcc: not found
../tools/configure: 1: ../tools/configure: sh-elf-ld: not found
[WARNING] The compiler you must use (sh-elf-gcc) is not in your path!
[WARNING] this may cause your build to fail since we cannot do the
[WARNING] checks we want now.
Using sh-elf-ld
../tools/configure: 3755: test: Illegal number:
../tools/configure: 1: ../tools/configure: sh-elf-gcc: not found
WARNING: You use an unpatched gcc compiler:
../tools/configure: 3804: ../tools/configure: sh-elf-cpp: not found
Warning: Could not determine target arch
Created Makefile
So, it seems not everything is prepared that it will work.
Where do I put the sh-elf-gcc ?
Or what do I have to do?  ???

When I select Advance and then Simulator it's working.

I'm not a Linux user, but can catch up fast as when told how things work.
Unfortunately I could not find anything about this on the Rockbox site.

Any help is much appreciated!


PS: I also tried the BigDisk approach with a 160 GB regular disk, but it was not working es well.
The Interface on the AJR board shows V2.1B.
Title: Re: sh-elf-gcc: not found
Post by: Renderking on September 08, 2013, 05:42:36 AM
Okay, I managed to get things done once I went through the "Simple Guide To Compiling In Linux ".

But now I have another problem:
Code: [Select]
error: firmware image is 205518 bytes while max size is 204800!
make: *** [/home/ubuntu/rockbox/build/ajbrec.ajz] Error 255

What can I do to make the firmware image smaller ??

Title: Re: sh-elf-gcc: not found
Post by: Renderking on September 22, 2013, 01:07:26 PM
so here the same ....

found my own solution:

When I make a build with RB version 3.9, it is still small enough for my Archos JukeBox Recorder, which is fine to me as it provides all the features I need.

I made my build available in the Big Disk Wiki here: (

Title: Re: sh-elf-gcc: not found
Post by: [Saint] on September 22, 2013, 05:19:31 PM
That's great and all...but, two things:

1: I don't see any sources.
2: Even if this existed on the Wiki previously undisturbed, the "right" place for these binaries is the Unsupported Builds (,36.0.html) section of the Forum so that people don't confuse them with binaries issued by Rockbox proper and understand that these builds are not supported.

Apologies if it seems bitchy, you're doing a good thing.

Title: Re: sh-elf-gcc: not found
Post by: nls on October 04, 2013, 01:11:52 PM
If you want to build a current rockbox for that target you need to remove some code from the build, the target's config file in firmware/export/config might have swomething you can turn off that you don't need