Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: trgz on August 29, 2013, 05:10:47 AM

Title: Rockbox iTunes iPod Classic 5th Gen 240GB Disk Mode
Post by: trgz on August 29, 2013, 05:10:47 AM
I thought I'd post up my discovery, if only at least for me, that I just couldn't figure out how to boot to my original firmware without the iPod 'going in circles' when I was trying to use iTunes to organize/transfer my music to my Rockboxed 240GB Classic 5th gen iPod. Then I 'accidentally' put the iPod into disk mode and, hey presto!, iTunes recognized it again and it'll happily sync. Windows does see the iPod as a drive when booted into Rockbox.
Of course this still means that the original firmware is still un-accessible and the only way I can seem to resolve this is to temporarily remove Rockbox and the bootloader (but I'm off to trawl the forums for a solution) - the original firmware seems necessary for me to use my iPod in my Pure bedside radio as it just sits there 'connecting' if it's booted into Rockbox, though I can listen to it via in my other docks.
(nb I know a lot of Rockbox users are going to be anti-iTunes, but I can write C# that'll do some fun stuff, with playlists and more, that I just haven't been able to do with other software so I'm sticking with it.)

Update: Somehow the iPod firmware has started to appear on reset rather than it continually looping (possibly after much synching?) though the original firmware doesn't think there's any songs on the iPod even though there's 170GB+ in use...
Title: Re: Rockbox iTunes iPod Classic 5th Gen 240GB Disk Mode
Post by: [Saint] on September 01, 2013, 11:58:55 PM
I highly suggest taking the time to read the manual (http://download.rockbox.org/daily/manual/rockbox-ipodvideo/rockbox-build.html)...

Rockbox supports dual-boot (http://download.rockbox.org/daily/manual/rockbox-ipodvideo/rockbox-buildch3.html#x5-290003.1.3), meaning both Rockbox and the Apple firmware are accessible, always.


[Saint]
Title: Re: Rockbox iTunes iPod Classic 5th Gen 240GB Disk Mode
Post by: trgz on September 02, 2013, 05:16:40 AM
The Manual was read but it didn't help me fix it. My repeated attempts to do a full uninstall/reinstall of the bootloader & Rockbox didn't sort my problem and it continued to loop with the apple logo only being displayed and the HD spinning quietly when I tried to boot to the original firmware(Manual: 3.1.3.); popping it into disk mode to sync with iTunes worked. After several (10+) syncs with iTunes I thought I'd see if it still 'looped' but was surprised to see the original iPod firmware, though without any songs listed.

Update:
Still able to get into disk mode, but original firmware now back to being stuck in a boot loop with Apple logo only