Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: Wilde_bill on May 15, 2020, 08:54:54 PM

Title: iriver H320 turning on issues (not battery problem)
Post by: Wilde_bill on May 15, 2020, 08:54:54 PM
Hi all,
I'm a long term Rockbox user but have never been great with forums (I always get the formats wrong, or post in the wrong place etc) so apologies in advance if this is in the wrong section. I've been using an iriver H320 with rockbox 3.13 since that version came out. It has worked flawlessly every day until about 2 weeks ago. The iriver wouldn't turn on (by pressing the play button) unless I plugged the device in to the computer via usb or the wall charger (I later discovered it's a lot more confusing then this see below). Taking this to be a battery problem, I ordered a new one (1700mah sino) and replaced it and unfortunately while the battery works, this was not the cause of the problem, furthermore I updated the firmware to the new Rockbox 3.15, and while this was also successful, the problem persists. Linking it to a computer lets me access all the files etc. (this doesn't mean the hdd isn't dying of course, but it seems fine). Since doing these things more details of the problem have come to light, and it's a little hard to repeatedly replicate everything I'll try to outline some of the things that happen:

1: If left 'off' for a little while, there is generally (see point 3 below) nothing I can do to turn it on from the system end, it's as if it is bricked or without charge, however if I plug it into the wall charger, or usb for even a second, it will boot up instantly, literally the flick of a switch will do it. Once on, it will work perfectly, the battery is fine, it still has the correct time, it remembers which track was playing etc. All of the buttons work perfectly, including the play/on button. I even listened to music for an hour or so. The battery reading at the start indicates a battery with full charge

2: I can turn it off manually, or leave it to turn itself off. If I am quick (generally a few mins) I can turn it back on again by pressing the play button, I don't need to hold it as I used to have to, I just tap it and it turns back on HOWEVER, more often than not the original Iriver firmware loads, not rockbox, I haven't a clue why the original loads, I am not pressing the record button with the on button (if I do press both, it shows the rockbox booting screen and switches to original). To make this more confusing rockbox will still load perfectly sometimes (though rarely) when I press the on button.

3: Generally, if I leave the iriver for a while, it will not turn on by any means aside from plugging it on as described above, however, I turned if off last night, and was able to turn it on perfectly this morning after about 12 hours. Unfortunately this was only temporary, and the problem is persisting.

I had a little look at one side of the motherboard while replacing the battery, and unless I am mistaken there isn't much that can be replaced by hand (large capacitors etc.)? So would I be right in assuming that if this is a mobo issue my poor Iriver is kaput? Of the things I can think of:
*Maybe the hard drive is dying? It's the most hard-wearing part after the battery, and this would almost make sense, except I don't see how it could explain booting into the original firmware?
*This is somehow a button issue (the most hard wearing parts after the other two, maybe there is something stuck under the pads or something?)
*This is an issue with the hardware that the firmware is flashed to, or the firmware install has become corrupted (I am unsure but it may be possible to remove everything to start again, but I have already updated rockbox fine).
*Another possibility I suppose is the board needs to be cleaned (it looked fine but the rubber separators looked like they were maybe starting to decay which could leave residue but again I'm only suggesting it because nothing else is coming to mind).
*Finally it is a motherboard issue, I have read a little about how charging circuits can be damaged etc. Is it possible to do any repairs on the motherboard? I have experience repairing large old computers and old game consoles, but everything is so big you can just desolder the affect part and replace it.

Anyhow, sorry for the long post, or if I have forgotten to include any relevant details, or if this is in the wrong section, I would greatly appreciate any advice if anyone here has experienced similar problems.
Many thanks in advance for any help anyone can provide

EDIT 19/05/10: I think I can rule out software/firmware as an issue. After trying everything else I completely uninstalled Rockbox and I removed the bootloader, formatted the drive and went back to factory settings. I then reinstalled everything via the Rockbox utility, all of the problems still persist, I can (I think) now also confirm that the battery is being drained while the system is off, if the system is  left off for a day and a half the battery will be completely empty from a full charge. This is still not the reason that the system will be intermittent in turning on however, because if I 'jump start it' by plugging it in for a second when the battery is full it will run for many hours. The hard drive seems more clicky then is used to be, I have run a whole bunch of tests on it, and no problems have come up. But for the battery drain I would almost think the hdd was starting to die (and needed a jump start to get spinning) however from my reading of past forums, the battery drain, if not caused by a bug, would have to be hardware related. As this spans two different batteries, that would then point to a motherboard issue. However I am still out in the weeds on this, I am trying to research how possible/impossible it is to diagnose and replace motherboard components.
Title: Re: iriver H320 turning on issues (not battery problem)
Post by: askvictor on June 18, 2020, 12:51:23 AM
I've just been trying to revive an old H340, whose battery has completely died, and discovered the following behaviour, all starting from it being off (I've completely disconnected the battery from it internally). If I plug in power, it boots to the original firmware (which in my case doesn't actually boot as I'm running a CF hard disk adapter). If I hold down play as I plug in the power, then let go, then press play again, it boots rockbox. If I plug in USB to the computer, then plug in power, it boots into rockbox USB bootloader mode, then if I unplug USB, boots fully into rockbox.

If yours follows a similar pattern, the power circuitry might be the problem.