Rockbox Technical Forums

Rockbox General => Rockbox General Discussion => Topic started by: Merzcat on December 18, 2021, 04:10:48 AM

Title: Rockbox ipod classic partitions being deleted
Post by: Merzcat on December 18, 2021, 04:10:48 AM
When I connect my rockboxed ipod to my computer it doesn't connect and allow me to transfer files.
I read the threads where people were told to hold the menu and select button for a few seconds then flip the hold switch, but doing that deletes my partitions forcing me to reinstall rockbox.
What is going wrong?
Title: Re: Rockbox ipod classic partitions being deleted
Post by: Merzcat on December 18, 2021, 04:18:40 AM
Ok so I connected my rockbox'd ipod to my windows xp machine and it worked perfectly fine.
For some reason windows 10 doesn't recognize the ipod if it's running rockbox.
Title: Re: Rockbox ipod classic partitions being deleted
Post by: Frankenpod on December 18, 2021, 04:41:47 AM
Does it work if you boot it into original-firmware mode before connecting it to the computer?

(As often pointed-out, that's probably the safest way to transfer files anyway)
Title: Re: Rockbox ipod classic partitions being deleted
Post by: Merzcat on December 19, 2021, 03:04:59 PM
Like I said, putting it into disk mode by holding menu+select and then flipping the hold switch deletes the rockbox partition.
Title: Re: Rockbox ipod classic partitions being deleted
Post by: saratoga on December 19, 2021, 04:59:10 PM
Is this with an SSD replacement for the original hard drive?
Title: Re: Rockbox ipod classic partitions being deleted
Post by: Frankenpod on December 20, 2021, 01:13:00 AM
Like I said, putting it into disk mode by holding menu+select and then flipping the hold switch deletes the rockbox partition.

You didn't mention disk mode, and I assume you meant holding play+select (that's what puts it in disk mode).  Menu+select would reboot it or put it into DFU mode.  Though I suppose if you rebooted it and then put hold on, you'd get into original firmware mode, so I'm guessing that's what you did?

What type of iPod is it?  If it's a 6th gen and it's been modified to be >128gb, that could cause that problem.