Rockbox Technical Forums

Installation / Removal => Manual Installation => Toshiba - Installation/Removal => Topic started by: linuxchuck on July 28, 2007, 09:30:36 PM

Title: [solved] Unable to get Rockbox to play ANY media files (MP3/MPG) On Gigabeat
Post by: linuxchuck on July 28, 2007, 09:30:36 PM
This was solved with the assistance of Soul-Slayer and Febs on the Rockbox IRC Channel.  Solution was that today's (28 July 07) build will not play media files on the Gigabeats.  I was informed to use an older build.

Thanks Soul-Slayer and Febs!

--- original post follows ---

Hello,

My first post here, so be gentle.

Here is the situation:

I have two MEGF20 Gigabeats that have been working flawlessly on the original firmware.  I have been waiting patiently to move them both to Rockbox.  I came back to the site today for the first time in several months to check on the progress, and found out that people are making it work!  I immediately went to the Gigabeat wiki page on rockbox.org, and followed the instructions to the letter.  I am a long-time Linux user (dating back to the "install from a stack of floppies" days) with fairly strong skills across multiple platforms.  That being said, I'm hoping I've made some sort of ridiculously simplistic mistake that has an equally simplistic resolution.

Everything installs fine.  I can boot Rockbox on both Gigabeats.  I can even play most of the plugins without issue.  (I say "most" because I simply haven't tried them all.)  I was the most excited about the mpegplayer plugin, so the first thing I tried was to convert a video I have using the guide on the mpegplayer plugin page.  Once converted, I put it in a new directory I created called "video" at the root of the Gigabeat's drive, and unhooked the USB cable (after unmounting, of course) to test it out.  As soon as I selected the mpg file in the interface, the button lights on the right "flickered", the Rockbox logo flashed across the top of the screen, and I was instantly sent back to the main menu.

A little confused, I decided that I might have had a bad conversion for the video... so I downloaded the 320x240 "Elephants Dream" video that was listed for the "ipod Video & Gigabeat" from the mpegplayer page.  Attempting to play that video resulted in the same exact behavior.

My next thought was perhaps a faulty Gigabeat.  So I performed the same steps on the second one I have on hand.  To the exact same results.  (I know, I know... the definition of insanity is performing the same actions over and over, and expecting different results.)

I decided to give video testing a rest, and just put some mp3s on one to listen while I worked on the other.  To make a long story short, attempting to play an mp3 on either Gigabeat results in the same problem.  I have a collection of ... well, I have a MASSIVE mp3 collection.  I've never run into a problem playing any of my mp3's on any device I own.  (I have a couple of Archos players as well.)  Even on the original firmware using Gigabeat Room, these mp3s worked on these same players.

My final attempt at troubleshooting was to completely delete the .rockbox directory from the root of the player's drives, and reinstall a clean version.  I did not reinstall bootloaders yet.

I downloaded the bootloader, and zip files offered from the install page on the wiki.
The URLs of each were:
http://download.rockbox.org/bootloader/gigabeat/FWIMG01.DAT
and
http://build.rockbox.org/dist/build-gigabeatf/rockbox.zip

If I were to try to tell you exactly how I installed Rockbox onto either of these players, I would simply be quoting the Gigabeat installation instructions from the wiki.

When I view the system information from the Rockbox menu, it displays this on both players:

Rockbox Info:
Version:  r14042-070728

Buffer:  28.990MB
Battery:  84% 11h 35m
Disk:  18.6GB
Free:  10.0GB

Here is my question:

Has anyone seen this behavior before?  I have a hard time believing that I have two defective Gigabeats considering that they work fine off of the original firmware.  Is there some step that I have possibly missed, or mis-performed?  I'd greatly appreciate any suggestions, or information I can get to get my Gigabeats successfully running Rockbox.

Thanks in advance!

Linuxchuck