Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: Matze88 on March 06, 2009, 06:36:38 AM

Title: H320 with CF Mod: First-Boot problems
Post by: Matze88 on March 06, 2009, 06:36:38 AM

I modded my H320 with a Kingston ElitePro 133x 32 GB CF-Card and the cheaper DealExtreme Adapter as mentioned in CFModGuide. Before I got my Kingston card I used a 256 MB Extrememory that did not show the following problems but some hangups when searching more than an hour forward/backward in a big mp3 directly after start.

I flashed the Bootloader from "" mentioned on the CFModGuide in Wiki.
My problem:
Everytime I boot my player after it has been turned off for about 15 seconds or longer it does not boot up. It stops right before the bootloader would output ATA information, the LED on CF Adapter stays on until I reset. After reset, everything works completely fine if i hurry to turn it on again.

When I plug the player to my computer with USB and do not turn it on by pushing the on button the bootloader comes up, flashes "bootloader USB mode" for a tenth of a second or so and then tells me
"I04: Ill. instruction 0003F94E4" and sometimes adress is "0003F94E0".
Sometimes I also get this message when I turn it on manually but then  address is "0003F2FC8" (most of the time) or "0003F2FD6". Resetting and replugging USB (sometimes I needed to do that more than one time) finally brought the player into USB mode. When it is booted, everything works really fine.

To me this seems like an error with initialisation routines, maybe wrong timing or even a hardware problem with insufficent voltage?

I wonder if I should set my CF adapter to master or to slave, both seem to work equally. Also another question: Is there a way to flash the bootloader from within rockbox? Because my original firmware won't boot with CF card ("Check HDD connection" ... "Check HDD").

Any ideas? Thank you!

Title: Re: H320 with CF Mod: First-Boot problems
Post by: peteswensson on March 07, 2009, 05:45:54 PM
I'm not one of the experts, so I can answer only one of your questions.  No matter what you try, the original firmware on the iRiver H300 series will not recognize, and will not boot from your CF card.  It does not have the capability.  "Check HDD" and "Check HDD connection" are its error messages for a dead or missing hard drive.  Hence you will need to keep around your 20 GB hard drive in case you ever need to reflash the firmware.

I have been fiddling around with the CF mod for about the last year, following a similar path to yours.  Some of the cards I have used have worked perfectly, and others not.  I started with fiscal caution, trying out an 8 GB Transcend 133X.  When it worked perfectly, I splurged on a 32 GB Transcend 133x.  Though the same make, the bigger card has been erratic.   It seems to consistently freeze if I try to fast-forward or fast-reverse through a song, and if I finish playing sudoku and try to go to a song.  Sometimes it would work if I waited for the drive search icon to go off between key clicks.  But not always.

It was all too disappointing.  So a month ago I bought a 32 GB RiData 233X, since Wintermute had reported success with it.  And, it has worked perfectly for me as well.
Title: Re: H320 with CF Mod: First-Boot problems
Post by: Matze88 on March 09, 2009, 06:22:41 AM
Thanks for your answer. I played around much with my H332 the last hour and the last days and did not get ANY freeze when it was running. the whole thing only happens on a "cold" boot. I have about one week left to return the cf card to the shop... But I do not think that I will do this. It is a bit enerving to reset the player every time I want to turn it on but when it runs it runs ;-) Maybe I will have a deeper look into the firmwareand try something like more wait stages on bootup or something like that but currently I do not have time for that.

I really appreciate any further opinions from someone who experiences the same problem as me or someone who maybe knows an answer...

Matthias Larisch