Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: wap32 on July 07, 2009, 08:05:45 AM

Title: Ipod 5g doesn't boot
Post by: wap32 on July 07, 2009, 08:05:45 AM
I was given a broken ipod and I was hoping I could repair it.

It gets stuck on the apple logo at boot, a popular problem.
However, I don't think it boots at all, the backlight doesn't come up and the hdd doesn't spin up or make any kind of noise.

Can't get into disk mode with select+play after reset (yes, I've insisted many times), connected to a computer or not, also tried resetting and activating hold (as I've seen suggested on the forums) with no result.

I just wanted to confirm with you guys that it really was bricked, and that short of a new board there's nothing to be done.
Title: Re: Ipod 5g doesn't boot
Post by: torne on July 07, 2009, 12:02:47 PM
If select+play to get to disk mode doesn't work, and the disk doesn't spin up, then the hardware is almost certainly dead. Which *bit* of the hardware might be subject to question, though. Can you get into the diagnostic mode (hold select and previous)?
Title: Re: Ipod 5g doesn't boot
Post by: wap32 on July 07, 2009, 02:30:58 PM
Select+prev turns the screen blank and it either freezes or shuts down (backlight stays off so I can't tell) and I have to reset it.

That and the absence of any clicking noises on the drive makes me thing the logic board has gone haywire.
Title: Re: Ipod 5g doesn't boot
Post by: LambdaCalculus on July 07, 2009, 03:24:58 PM
If it is the logic board that has gone haywire, then you can replace it or just get another iPod (which may be cheaper than getting the part itself).
Title: Re: Ipod 5g doesn't boot
Post by: wap32 on July 08, 2009, 04:28:22 AM
Yeah, it appears I'll have to buy a new board.

Thanks for the input guys.  :)