Rockbox Technical Forums

Support and General Use => Theming and Appearance Customization => Topic started by: cereal_killer on August 27, 2019, 02:39:51 PM

Title: Progressbar not working in Wide Cabbie theme for ZEN X-Fi3
Post by: cereal_killer on August 27, 2019, 02:39:51 PM
The following code does not work to make the progressbar appear on Wide Cabbie theme for the ZEN X-Fi3 (http://themes.rockbox.org/index.php?themeid=1&target=creativezenxfi3):

Code: [Select]
# Progressbar
%pb(5,182,166,8,pb-176x220x16.bmp)

replacing it with

Code: [Select]
# Progress Bar
%V(5,182,166,8,-)
%pb(0,0,-,-,pb-176x220x16.bmp)

from the original Cabbiev2 theme makes the icons on the bottom disappear.
Any hint on how this can be fixed?
Title: Re: Progressbar not working in Wide Cabbie theme for ZEN X-Fi3
Post by: cereal_killer on August 30, 2019, 07:42:21 AM
Does anyone know a fix for this?
Title: Re: Progressbar not working in Wide Cabbie theme for ZEN X-Fi3
Post by: Bilgus on August 30, 2019, 09:44:57 AM
Code: [Select]
# Progressbar
#%pb(5,182,166,8,pb-176x220x16.bmp)
# Hold icon
%?mh<%xd(Aa)|%xd(Ab)>
# Battery icon
%?bp<%?bc<%xd(Ba)|%xd(Bb)>|%?bl<|%xd(Bc)|%xd(Bd)|%xd(Be)|%xd(Bf)|%xd(Bg)|%xd(Bh)|%xd(Bi)|%xd(Bj)>>
# Volume icon
%?pv<%xd(Ca)|%xd(Cb)|%xd(Cc)|%xd(Cd)|%xd(Ce)|%xd(Cf)|%xd(Cg)|%xd(Ch)|%xd(Ci)|%xd(Cj)>
# Shuffle icon
%?ps<%xd(D)>
# Repeat icon
%?mm<|%xd(Ea)|%xd(Eb)|%xd(Ec)|%xd(Ed)>
# Playback icon (Stop/Play/Pause/Ffwd/Rew)
%?mp<%xd(Fa)|%xd(Fb)|%xd(Fc)|%xd(Fd)|%xd(Fe)>
###############################
# Viewport definitions below: #
###############################
# Progressbar
#%pb(5,182,166,8,pb-176x220x16.bmp)
%V(5,182,166,8,-)
%pb(0,0,-,-,pb-176x220x16.bmp)
# Progress text viewport, using sysfont - always displayed:

You just need to move the Viewport below the Icons (or make the VP bigger to accommodate them)
Title: Re: Progressbar not working in Wide Cabbie theme for ZEN X-Fi3
Post by: cereal_killer on August 31, 2019, 11:29:21 AM
Thank you Bilgus, that worked. This was new to me, that the position of the code in the .wps file matters. So I think I need to familiarize myself more with the WPS syntax.
Title: Re: Progressbar not working in Wide Cabbie theme for ZEN X-Fi3
Post by: Bilgus on August 31, 2019, 11:31:53 AM
personally I don't like the WPS syntax very much there are lots of little gotchas like that