Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: rclott on January 08, 2008, 04:42:22 AM

Title: H320 Manual Install - Illegal Instruction at Boot
Post by: rclott on January 08, 2008, 04:42:22 AM
I just tried to install Rockbox on my Korean H320, following all the instructions in the excellent manual.  I patched version 1.28K firmware, burned it, and when it boots the following happens.  Booting information is displayed (version, checksum, etc.).  Then very briefly I see the splash screen, followed by "I04: IllInstr at 00000002".  Tried the installation twice, same result.

I *can* hold the REC key and get it to boot up the iRiver firmware, so the problem is not catastrophic.

Thoughts?

-Chris
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: nls on January 08, 2008, 05:11:15 AM
Redownload rockbox to make sure the file is good and check the disk for errors.
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: muesli on January 08, 2008, 06:15:38 AM
i can confirm the same. my h330 was running without probs with a build 3-4months old and crahes immediately with the current displaying that error-message
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: AlexP on January 08, 2008, 06:35:04 AM
There is a problem with the current build at the moment for at least H300 and X5, that the developers are aware of.  Until it is fixed (which I'm sure will be very soon), please use version r16021 or earlier.
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: muesli on January 08, 2008, 06:39:04 AM
ok...sorry, but where do a find that build?
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: AlexP on January 08, 2008, 06:42:05 AM
A fix has just been committed.  Leave it a few minutes until the front page updates then the newest current build should be fine.
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: muesli on January 08, 2008, 12:44:27 PM
fixed it, thx  ;D
Title: Re: H320 Manual Install - Illegal Instruction at Boot
Post by: rclott on January 08, 2008, 11:54:06 PM
I discovered the buggy version information from the IRC channel just after making the original post.  I selected a version from the previous day (I think it was 7th Jan) and now it works fine.  Now I only have to learn to use this new interface, but so far I am very satisfied.  -Chris