Rockbox Technical Forums

Rockbox General => Announcements => Topic started by: Bilgus on April 01, 2021, 09:37:02 PM

Title: Looking for Beta Testers for next release
Post by: Bilgus on April 01, 2021, 09:37:02 PM
We need beta testers to make sure all the targets still work with the latest dev builds

There have been a lot of changes since the last release.
we need to test all the targets in the build list with recent development builds if we are
to release them in the next stable release

If you have a device that you know for sure works with a current dev build (and is not already in the table)
give us a comment


Thanks -- from all of us!


Agptek Rocker  WORKS!
AIGO EROS Q/K  WORKS!
FiiO M3K (native) WORKS
Toshiba Gigabeat F/X  WORKS!
Toshiba Gigabeat S  WORKS!
iriver H10  WORKS!
iriver H10 5GB  WORKS
iriver H110  UNTESTED
iriver H120  WORKS!
iriver H300  WORKS!
Philips HDD1630  WORKS!
Philips HDD6330  WORKS!
HiFi E.T MA8  UNTESTED
HiFi E.T MA9  UNTESTED
HIFIMAN HM-601 UNTESTED
HIFIMAN HM-602 WORKS
HIFIMAN HM-603 UNTESTED
HIFIMAN HM-801 UNTESTED
iAudio M5  UNTESTED
iAudio X5  WORKS
iBasso DX50 WORKS
iBasso DX90 UNTESTED
IHIFI 760  UNTESTED
IHIFI 770  UNTESTED
IHIFI 770C  UNTESTED
IHIFI 800  UNTESTED
IHIFI 960  UNTESTED
iPod (1G/2G) UNTESTED
iPod 3G UNTESTED
iPod Mini 1G  WORKS!
iPod Mini 2G  WORKS!
iPod Nano  UNTESTED
iPod Nano 2G  WORKS!
iPod 4G Greyscale  WORKS!
iPod Color/Photo  WORKS! [#Screen Tearing]
iPod Video (5/5.5G) WORKS!
iPod Classic (6G/7G) WORKS!
Olympus M Robe 100 WORKS!
Olympus M Robe 500 BOOT HANG
MPIO HD200  UNTESTED
MPIO HD300  UNTESTED
Onda VX747  UNTESTED
Onda VX767  UNTESTED
Rockchip rk27xx  PLAYBACK ISSUES
SanDisk Sansa c200  WORKS!
SanDisk Sansa c200v2  UNTESTED
SanDisk Sansa Clipv1  WORKS!
SanDisk Sansa Clipv2  WORKS!
SanDisk Sansa Clip Zip  WORKS!
SanDisk Sansa Clip+  WORKS!
SanDisk Sansa e200  WORKS!
SanDisk Sansa e200v2  WORKS!
SanDisk Sansa Fuze  WORKS!
SanDisk Sansa Fuze+  WORKS!
SanDisk Sansa Fuzev2  WORKS!
Samsung YH-820  WORKS!
Samsung YH-920  WORKS!
Samsung YH-925  WORKS!
Samsung YP-R0  WORKS!
Samsung YP-R1  UNTESTED
Sony NWZ-E350  WORKS!
Sony NWZ-E370  UNTESTED
Sony NWZ-E450  UNTESTED
Sony NWZ-E580  WORKS!
Sony NWZ-S750  UNTESTED
xDuoo X20  UNTESTED
Xduoo X3  WORKS!
xDuoo X3ii  WORKS!
Creative ZEN  WORKS!
Creative ZEN Mozaic  UNTESTED
Creative ZEN X-Fi  WORKS
Creative Zen X-Fi2  WORKS!
Creative Zen X-Fi3  WORKS [radio issues and noise with SD card access]


PS. Have issues? See us in IRC!

https://www.rockbox.org/irc/


Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on April 03, 2021, 12:27:08 AM
20 % coverage so far
Title: Re: Looking for Beta Testers for next release
Post by: Frankenpod on April 03, 2021, 12:49:39 AM
How recent do you mean by 'recent'?

I've been using fairly recent (last month or so) releases in ipod classics and videos.  Just yesterday updated a video to the latest dev release - it seems OK so far.

Only issue I've had, as I probably mentioned previously on the forum, is that sometimes the ipod forgets that it's supposed to turn the backlight off after N seconds (until you go into the menu and set the backlight shut-off time again, whereupon it starts working correctly again).  Still can't quite work out under what circumstances this problem starts happening, though playing a game from the plugins seems to be one way to cause it to happen.  Don't remember this happening with older versions, from, say, last year?
Title: Re: Looking for Beta Testers for next release
Post by: Milardo on April 03, 2021, 01:23:59 AM
Sony NWZ-E353 works fine for me.

I don't know if it is stable though.

One thing that has been fixed: "Audio stutters when backlight is off"

issue has been resolved for some time now.

Title: Re: Looking for Beta Testers for next release
Post by: johnb on April 03, 2021, 04:49:26 AM
The following boot and play music:
SanDisk Sansa e200     
SanDisk Sansa e200v2     
SanDisk Sansa Fuze     
Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on April 03, 2021, 05:57:19 AM
Thanks Everyone Added!

Frankenpod that video report is perfect recentish build turns on plays music thats good enough
Title: Re: Looking for Beta Testers for next release
Post by: Frankenpod on April 03, 2021, 06:07:14 AM
Updated a 7th gen to the e09df1ce5b-210403 dev version, and for a moment thought 'oh no, it's not working' because it produced no sound when a track was played.  But it turned out the audio jack connector had become physically disconnected (it's a recent flash mod, probably didn't close the connector catch properly), and after re-openning it and fixing that all seems to work so far.

(finding the ability to alter volume via the quick menu screen is a useful tweak)
Title: Re: Looking for Beta Testers for next release
Post by: cela on April 03, 2021, 10:49:27 AM
Rockchip rk27xx         Tested version e09df1ce5b-210403 , boots up into menu, but quickly skips and cycles though any selected tracks without playing any thing.
Samsung YP-R0          Works! version e09df1ce5b-210403
Sony NWZ-E384        DEAD, waiting for a new battery
Creative ZEN X-Fi      Works! version e09df1ce5b-210403
Creative Zen X-Fi2     Works! version e09df1ce5b-210403

Need to charge up the rest of my players to test the rest!
Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on April 03, 2021, 10:51:35 AM
Cela Rockchip rk27xx
would you be available to test builds for us at some point in IRC?
Title: Re: Looking for Beta Testers for next release
Post by: cela on April 03, 2021, 11:05:26 AM
Cela Rockchip rk27xx
would you be available to test builds for us at some point in IRC?

Last build I installed was from 2016! , I think I modified the build for the button configuration so It's probably not an issue with Rockbox, I'll try and find the button patch and retest it, probably not worth spending a lot of time on as rk27xx is just a reference build that some of the Hifiman players use, don't have an Hifiman so can't test if they are affected.  My player is just an unbranded cheap Rk27xx on its last legs.
Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on April 03, 2021, 11:16:02 AM
Hmm generally that file skipping thing is a buffer or disk issue so its quite possibly the code
Title: Re: Looking for Beta Testers for next release
Post by: saratoga on April 03, 2021, 02:43:47 PM
Clipv2 data aborted when first booted, but actually worked fine after a pair of reboot cycles, so I'm going to make it as ok unless I can get it to fail again.
Title: Re: Looking for Beta Testers for next release
Post by: chris_s on April 03, 2021, 03:07:18 PM
iPod 4G and iPod color/photo both work. The latter has screen tearing, but that's not new (I think).
Title: Re: Looking for Beta Testers for next release
Post by: ulmutul on April 03, 2021, 05:07:57 PM
Tested the following players, all of them are working:
* Samsung YH820
* Samsung YH925
* iPod Mini 1st gen.
* Creative ZEN
Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on April 04, 2021, 10:39:10 PM
cela I'm still convinced the rk27xx issue is an alignment problem, probably a mis-configured memory layout or something

here is a build with the alignment padded with nops to match the working build could you give this one a try?
https://www.mediafire.com/file/gslq6hqsehh73tm/nopnopalign_rockbox-full.zip/file
Title: Re: Looking for Beta Testers for next release
Post by: cela on April 05, 2021, 08:26:01 AM
cela I'm still convinced the rk27xx issue is an alignment problem, probably a mis-configured memory layout or something

here is a build with the alignment padded with nops to match the working build could you give this one a try?
https://www.mediafire.com/file/gslq6hqsehh73tm/nopnopalign_rockbox-full.zip/file
Still has the same playback issue,files are .mp3 and has the same issue on .flac, button click sound works though.
Title: Re: Looking for Beta Testers for next release
Post by: Lucius on April 10, 2021, 08:49:19 AM
iBasso DX50 (448f98d9c0):

don't start, I get error:

*PANIC*
ERROR button_init_device: No input devices.
pc: 00066f2c sp: be851ae0
Title: Re: Looking for Beta Testers for next release
Post by: majjam on April 10, 2021, 09:50:33 AM
Sony NWZ-E580   WORKS
Title: Re: Looking for Beta Testers for next release
Post by: speachy on April 10, 2021, 10:27:03 AM
iBasso DX50 (448f98d9c0):

don't start, I get error:

*PANIC*
ERROR button_init_device: No input devices.
pc: 00066f2c sp: be851ae0

Thanks for the report!  This should now be fixed, in rev 1303be343 (still compiling as I write this, but should be available on the dev build page in about 10 minutes)
Title: Re: Looking for Beta Testers for next release
Post by: Lucius on April 10, 2021, 12:41:31 PM
iBasso DX50 (448f98d9c0):

don't start, I get error:

*PANIC*
ERROR button_init_device: No input devices.
pc: 00066f2c sp: be851ae0

Thanks for the report!  This should now be fixed, in rev 1303be343 (still compiling as I write this, but should be available on the dev build page in about 10 minutes)

It’s work now, but I don’t see external SD card in File Browser, only internal storage.
Title: Re: Looking for Beta Testers for next release
Post by: b0hoon on April 10, 2021, 01:42:23 PM
Gogear SA9200, HDD1630, YH-920 and m:robe 100 works with 1303be3437.
Title: Re: Looking for Beta Testers for next release
Post by: speachy on April 10, 2021, 08:36:06 PM
It’s work now, but I don’t see external SD card in File Browser, only internal storage.

Hmm.  I think I know why that is happening, but I don't know enough about the dx50/dx90 platform to fix it yet.

Do you recall where in the filesystem the external sdcard is mounted?
Title: Re: Looking for Beta Testers for next release
Post by: Lucius on April 11, 2021, 04:10:32 AM
It’s work now, but I don’t see external SD card in File Browser, only internal storage.

Hmm.  I think I know why that is happening, but I don't know enough about the dx50/dx90 platform to fix it yet.

Do you recall where in the filesystem the external sdcard is mounted?

external sdcard is mounted:

/dev/block/vold/179:1 /mnt/external_sd
Title: Re: Looking for Beta Testers for next release
Post by: cereal_killer on April 11, 2021, 02:51:11 PM
I tested some devices using Version e4345f2db8-210411 and report the results:

iAudio X5 generally works, but pictureflow crashes and open plugin doesn't work from the wps context menu
Creative Zen X-Fi3 works, but has no sound on radio and has constant noise especially when using a sd card
Olympus M Robe 500 hangs on boot like other builds, only c710ab65bd-200512 works
iriver H10  6Gb works
Title: Re: Looking for Beta Testers for next release
Post by: speachy on May 18, 2021, 09:25:42 AM
Rockchip rk27xx         Tested version e09df1ce5b-210403 , boots up into menu, but quickly skips and cycles though any selected tracks without

I got the HIfiman HM-602 going, and it works fine with no issues at all.  It's built on the same rk27xx SoC family, so it would seem that any issues with the generic rk27xx port are either due to something unique to that port or the hardware itself.

Title: Re: Looking for Beta Testers for next release
Post by: peterz on January 25, 2022, 06:34:38 PM

Don’t know if anyone is still monitoring this thread … I hope so. I’ll try to send this message to the developer’s IRC, but not sure if I have the capability to do so right now.  Sorry for the long note, but I’m trying to give as much detail as I can.

This is for the iBasso DX90 player (which is shown as untested for current builds in the list of devices).

The DX90 boots and plays music with the latest daily build (2022 0122) BUT there is a problem with the builds that came about sometime between August 2020 and December 2022.
I can’t comment on the various plugins, scripting etc, as I’ve not used these, but the below is the only issue I’ve found in displaying, playing and navigating files.

The problem is that Rockbox thinks it is plugged into USB power even when it is not.
•  Every theme I try always shows the device as plugged into usb power and not running off battery. 
   The themes that show a percentage of battery remaining and the stock status bar do so properly,    but they show as plugged in as well.
•  Backlight  (and hence touchscreen activation) only responds to the “Backlight (While Plugged In)” setting,
   the General Settings: Display: LCD Settings: Backlight is ignored  (ie, I can set Backlight time to 15 seconds, and
   backlight (while plugged in) time to 60 seconds, and the backlight stays on for 60 seconds, no matter what.
• The Backlight Exemptions are enabled but the exemption settings are ignored, and the “disable on external power”
   setting also does nothing.  That is, the backlight turns on when there is any key press at all, even when that key
   should be exempted (like volume up/down).  The keys appear to be mapped correctly in other functions, so the
   problem is likely rockbox thinking it is plugged in.
• USB mode (mass storage, charge, ask) the “ask” doesn’t function, but that’s probably because it thinks it’s already
   plugged in. It also doesn’t switch between modes when plugging in while a key is pressed, I imagine same reason.

This problem exists in the 3.15 builds I have been able to find from Dec 28, 2021 to Jan 22 2022.
(I don’t have the environment/capability to do a build from source).

An August 4 2020 build mostly works:
I retrieved a rockbox dx90 build from the Wayback Machine, for Aug 4, 2020 - this was the only earlier v3.15 I could find, and this does mostly work - themes correctly show either plugged in or battery power, the display backlight operates properly, and all but one of the backlight exemptions are working, the exception being the play/pause button which wakes up the backlight even when the exemption is set.
I don’t know about USB settings, because the “ask” option isn’t implemented for this build.

Also, a suggestion: I appreciate very much the development builds for the DX90, but if daily builds are being done on a device, please keep around/make available the base version of the release somewhere, probably in the Rockbox Manual Install Archives.

BTW, I really like the addition of the ability to get track info (artist etc) from the playlist viewer that was implemented in the Dec 28, 2022 build - a good job!.  Hopefully the above issues can be addressed in the latest builds, as I’d really love to be using this feature (the above backlight problems make rockbox not so good for my usage so I’ll use an earlier version for now).  Please let me know if this message is noted and/or addressed.

My thanks for your / the developers attention and efforts over the years -
peterz



Title: Re: Looking for Beta Testers for next release
Post by: speachy on January 26, 2022, 07:16:46 AM
Hmm.  This is strange.  We have a report of the DX50 working, and that supposedly has an identical base platform (including powermgmt) to the DX90.

For sanity's sake, can you rename your existing .rockbox directory and extract the current nightly build and see if that works properly?  I want to make sure there's nothing lingering in the configuration that might cause this..

Title: Re: Looking for Beta Testers for next release
Post by: peterz on January 26, 2022, 07:51:41 PM
OK - done. Still have the problem - I agree, very strange.

Extracted 20220126 build and installed.  There was no config.cfg file, so it used all defaults.

• Theme and status bar both showed plugged into USB power when it was not.  I had not set up any configuration at all, and still the status bar showed plugged in as did the stock WPS theme.
• I changed the backlight (while plugged in) time, and the backlight operated as if it were plugged in (only paying attention to the (while plugged in) timeout).
• I then set the volume, seek, skip and play/pause keys to be exempted from waking up the backlight (and enabled the options).
    The volume, skip and seek keys worked as they should.  The play/pause key still woke up the backlight no matter what.
• USB mode “ask” doesn’t ask, just goes directly to mass storage

Just for so, I copied my default configuration file to this .rockbox and rebooted- there was no difference to the above findings.
For whatever reason, rockbox thinks it is running plugged in.

The August 4 2020 build works, theme and status bar and backlight all operate as if running from battery power (although it does have the problem with the play/pause key waking up thes backlight) - both with and without a config.cfg file on boot.

So, sometime between August 2020 and now, something broke.
Could some bit of DX90 specific code be checking if it is plugged in and always returning “true” (or something similar).

Also - and I have no idea if this applies to the above issues, but just for completeness with potential issues on DX90:
   I was looking around at some of the plugins, and the Stopwatch plugin breaks with
      apps/stopwatch.lua: 283: attempt to call field ‘touchscreen_set_mode’ (a nil value) stack traceback: 
      /stopwatch.lua:23 in main chunk

thanks
peterz
Title: Re: Looking for Beta Testers for next release
Post by: Bilgus on January 28, 2022, 04:34:00 PM
peterz the lua plugin has nothing to do with the other issues I just missed one when I changed the api

EDIT

looking at the source I did indeed get that one,

when you put on your new builds did you just copy over an existing install?

can you try renaming your current .rockbox folder and then unzip the latest dev version on there clean?

that could also be your issue with the backlight exemptions..

Title: Re: Looking for Beta Testers for next release
Post by: peterz on January 28, 2022, 06:09:01 PM
I did a clean install.
Unzipped the latest  build, renamed the .rockbox folder on the DX90 to XXX, and copied .rockbox from the latest build onto DX90.
Rebooted and ... still have the problems (the battery icon shows as plugged in, whether it is or not. - I have to change defaults to get to the other problems, but they still exist when I do.) As far as the backlight exemptions - the volume, seek/skip keys do work as they should, it is just the play/pause key that always lights up the backlight.  It does this even in the August 2020 build.

The rest of the issues go away when I install the August 2020 build, or a June 9 2015 build I originally was using.

I did notice that in the 2020 build, when plugged into USB power and the USB option set to charge only, the battery icon shows as charging (with a sawtooth line in the icon) and this does not happen in the latest builds.

???
Title: Re: Looking for Beta Testers for next release
Post by: reggieb on October 03, 2022, 04:29:12 PM
I just put this on a HiFiMan HM-801 and so far everything is working alright. At one point I did get a strange "Scanning Disk" or something to that effect that seemed to prevent input soon after doing a database scan, but since then, there haven't been any issues. I haven't tested everything as I've just been playing around on the 801 today, but I will update if I do run in to any issues.