Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: allanbav on January 18, 2007, 09:06:34 PM

Title: cygwin compiling error
Post by: allanbav on January 18, 2007, 09:06:34 PM
I attempted to complie Senab's source (http://www.senab.co.uk/rockbox/download.asp)  just so I can get the hang of actually compliling rockbox. I went through the compliling manual with little trouble but have now got stuck.

After I make the make file and type "make" an error arises.

http://img155.imageshack.us/img155/2546/cygmh0.png

I have no understanding what the error is so I ask for help.

Thank you for anyones time.
Title: Re: cygwin compiling error
Post by: Llorean on January 18, 2007, 09:13:23 PM
As with everything relating to unsupported builds, you should ask in his thread if you can't get his sources to compile.
Title: Re: cygwin compiling error
Post by: allanbav on January 18, 2007, 09:21:48 PM
Blast!
Alright, I asked here because I thought the error was because of something I did (during installation,typing etc.)
Title: Re: cygwin compiling error
Post by: Llorean on January 18, 2007, 09:25:39 PM
It looks like it's a problem with the source itself, but you could've tested your install with clean official sources too before asking.

The rules regarding unsuportted builds apply to all aspects. The official source is available, and you can spend the five minutes to download, extract, and attempt to compile before posting.
Title: Re: cygwin compiling error
Post by: allanbav on January 18, 2007, 10:26:33 PM
well ok, I downloaded the official source and decided to make a simulator.
This is what happened after I type "make"

(http://img484.imageshack.us/img484/7812/cyg2bq0.png)

any suggestions?

Title: Re: cygwin compiling error
Post by: saratoga on January 18, 2007, 10:37:09 PM
Never seen that error before, but it sounds like it wants a perl interpreter, but can't find one.  Try typing "which perl" and seeing if it gives you a path.

If not, you can install perl from the cygwin installer pretty easily.