Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: ZeRøB on August 17, 2006, 07:37:21 PM

Title: RobBuild :: Trouble
Post by: ZeRøB on August 17, 2006, 07:37:21 PM
I am making a new RobBuild. I never released the first one, but I might release this one. It's perfect for the average RB user that wants just a little bit more, but not a big change like julius' builds (I would be aperson loike that lol)

It's just not 100% finished yet, and I can't compile...

I have these patches:
-- album_art_v5.10.patch
-- bmp_resize_v0.99.3.patch
-- menu_buttons.patch
-- rockbox-wheel_absolute_patch_v4.1.patch
-- rockboy_wheel.patch

I had to modify a few in order to be able to patch, I kept on getting errors but I fixed thim with my minimum knowledge of patches. I didn't do any major changes. Finally, all patches work and my binary is patched. I configured my make file, so I start making. After a while...:

Code: [Select]
CC recorder/bmp.c
recorder/bmp.c: In function 'read_bmp_file':
recorder/bmp.c:142: warning: 'rgb_work.red' may be used uninitialized in this fu
nction
recorder/bmp.c:142: warning: 'rgb_work.green' may be used uninitialized in this
function
recorder/bmp.c:142: warning: 'rgb_work.blue' may be used uninitialized in this f
unction
CC recorder/icons.c
CC recorder/keyboard.c
CC recorder/peakmeter.c
CC recorder/widgets.c
CC recorder/backdrop.c
CC gui/color_picker.c
CC pcmbuf.c
CC playback.c
playback.c: In function 'audio_load_track':
playback.c:1790: error: too few arguments to function 'get_metadata'
make[1]: *** [/home/guest/rockbox-daily-20060817/build/apps/playback.o] Error 1
make: *** [all] Error 2
Always, when I want to make my custom build, I seem to have this much trouble... Is it just me, or is something else wrong? I know playback.c is modified by the album_art patch, but that patch is so new, it should actually work...

Does anyone know a solution for this problem that isn't "dump the patch"?
Title: Re: RobBuild :: Trouble
Post by: Llorean on August 17, 2006, 07:42:20 PM
It tells you specifically what lines in the .c files are having problems. You've also already posted this exact same question elsewhere.
Title: Re: RobBuild :: Trouble
Post by: ZeRøB on August 17, 2006, 08:16:55 PM
With the statement that I should better open a new thread since I was going off topic in that thread, and i did so now. The patch is brand new, so I guess it should work with the newe sources. I already had to modify the +++ rules since they all had "/rockbox" in it which prevented cygwin from finding the right file to patch...
Yes, it tells me what rule of playback.c has trouble, but since this is supposed to be a working release of the patch, I shouldn't have to see this. Llorean, I have the feeling that you don't like helping me, since you act very cold to me. Am I being one of them annoying n00bs? (You know, not just a n00b, but an annoying one)

Instead of telling me everytime what I already know, could you pléase help me by telling me what I could do to fix it, since this isn't really helping me any further.
Title: Re: RobBuild :: Trouble
Post by: Llorean on August 17, 2006, 08:22:46 PM
Well, the thing is, my responses aren't really intended as cold. The idea is that it's best for people to fix things for themselves. That's why I so often say things blaringly obvious like "Try reading the manual" or in this case:

1) Try getting clean sources from CVS (using the CVS commands, not the source archive) then try installing one patch and compiling. If this works, remove it, and try the next, and so on, until you can identify if any one patch is causing the problem.

2) If that one patch is causing the problem, ask the patch author about it, specifically mentioning it in the flyspray thread regarding that patch.

3) If no single patch is causing the problem, figure out which two don't combine safely, then work on fixing those by going to the line number in the file mentioned, and fixing the issues it's telling you about.

One should never assume that the newest version of a patch will work, since the sourcecode changes several times a day.
Title: Re: RobBuild :: Trouble
Post by: ZeRøB on August 18, 2006, 04:33:54 AM
Alright, now that is an answer that helps me on. Thanks, looks like my first flyspray comment is on its way.