Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: ZOS474 on September 19, 2020, 05:10:35 PM

Title: Clip Zip Screen Problem
Post by: ZOS474 on September 19, 2020, 05:10:35 PM
I thought I had lost my last Clip Zip when the screen refused to show anything but garbage characters and all in one column and the unit wasn't recognized via USB on any of the computers I tried. Neither resetting the unit nor rebooting back to the original OS worked (the latter appeared to work, but then failed because it told me I had no free memory on the unit and to delete some files, which I couldn't do because I couldn't connect via USB to delete any files.)  Considering the message I got from the original OS about memory, I rebooted into rockbox and by my vague memory of the menu structure went to Files and selected the first folder, then long-pressed to get the context menu and clicked down 5 times to get to the directory delete menu item. I clicked that and then again for Yes. (Couldnt see any of this of course, just had to hope it was working.) Doing that managed to free up some space, which allowed me to reboot into the original OS and switch to MTP mode for the USB (in MSC mode, it still wouldn't register on my computer.) From MTP mode I managed to delete some more directories when plugged into my computer, but that didn't help with anything. I then, however, noticed a format option in the original OS, which I did, and which (I guess) somehow resets the original OS and wipes all music etc. from the internal disk.  I then switched to MSC USB mode and was finally able to have the Clip Zip show up in Windows.  Once there I reinstalled rockbox with the rockbox utility and now all good again.  I hope this helps someone facing a similar problem...