Rockbox Technical Forums

Installation / Removal => Manual Installation => Cowon - Installation/Removal => Topic started by: diputz42 on June 13, 2007, 01:18:01 AM

Title: HUGE problem booting
Post by: diputz42 on June 13, 2007, 01:18:01 AM
I recently installed rockbox on my iaudio x5L and it worked fine.  I was having some fun playing with the features and decided to update the rockbox firmware.  I don't remember the series of events that lead to the current status of my x5, but here's the problem:

It won't boot up rockbox nor will it flash original cowon firmware (2.10e)

I'll try to describe everything that I'm experiencing so that whoever helps me has a better understanding of what's going on.

Currently, when I plug the x5 in to the power supply or USB via the sub-pack, the screen I see is the default blue "iAudio" screen, followed by the default blue "Charging" or "Connected" screen, respectively.  When I remove either the power supply or USB adapter, I see the default blue "iAudio - Good Bye" screen.

The \.rockbox folder is currently in my x5's main directory and this is the screen I see when trying to turn on my x5:
Following this screen, the device shuts off.

Now, I go in via USB (without DC plugged in) to delete the \.rockbox folder and I copy the official Cowon firmware (2.10e) x5_fw.bin into the \FIRMWARE folder.  I turn off the x5 either by removing the sub-pack or holding the power switch, plug in the sub-pack with DC plugged in.  The result is the default blue "iAudio" splash screen, which stays for a few seconds, then the screen goes to the default blue "Charging" screen.  The firmware seems to not flash.  When I then try to power on the x5, this is the screen I see:
Again, after this screen, the device shuts off.

Does anybody have a solution to this problem?  I know I'm following the directions to reflash the x5, but somehow, nothing I do is working...  Thanks in advance for any solutions!
Title: Re: HUGE problem booting
Post by: scorche on June 13, 2007, 11:29:50 PM
Error -5 typically means you put the wrong binary on the device (as in are you sure you put the x5 build on?).

As you deleted the folder, you got the -1 error which means that there is no file.
Title: Re: HUGE problem booting
Post by: diputz42 on June 15, 2007, 04:33:04 PM
No.  I'm 100% sure I'm using the correct binary with the right builds.  My biggest problem right now is that the x5 refuses to flash any new firmware I put in the FIRMWARE directory... including factory Cowon firmware.
Title: Re: HUGE problem booting
Post by: gnu on June 18, 2007, 05:51:30 AM
Just asking: have you tried restarting it with the reset button on the side?
I'm quite sure it won't help, but it's free and there's always hope...
Title: Re: HUGE problem booting
Post by: canned soup on June 28, 2007, 10:03:49 AM
I had the same problem, exactly the same from your description, and never found a solution.  I did test and find I could  reflash rockbox over and over but never the OF.  Note the size difference in the files.  Anyway, my x5 had other problems and was being returned for repairs.  They swapped the main board for $100 to get back to OF.  Does your player exhibit any other problems?  Mine had a garble every so often that was predictable so I'm assuming problems with the ram buffer.   Would be interesting to know if it is a mainboard problem or FM issue.   Mine came back yesterday.  I am going to try dual boot this time.
good luck
Title: Re: HUGE problem booting
Post by: diputz42 on July 08, 2007, 11:29:58 PM
It seems as though updating firmware is a lottery on this thing.  It usually won't work, but on a rare occasion, and I mean once every few hundred tries or so, it will work.  I got lucky and was able to install a dual boot firmware which allowed me to use both rockbox GUI and factory cowon GUI.  But now it's doing the same thing again: I'm getting the "-5" error when trying to load rockbox.  Any ideas?.