Rockbox Technical Forums

Rockbox Development => Starting Development and Compiling => Topic started by: jswetzen on April 10, 2007, 10:42:35 AM

Title: VMware problems...
Post by: jswetzen on April 10, 2007, 10:42:35 AM
EDIT: I solved the nerworking problems but can't find out how to access a flashdrive in Debian.


I usually find all the answers I need by searching, but this time it failed so hopefully someone can help me.  :P

Before the change from cvs to svn I used cygwin to compile rockbox without any problems at all, unfortunately I couldn't download the sourcecode after installing svn. I decided to try VMware instead!

Now my problems are that I cannot get internet working on the virtual machine,  I can't find the samba shared folder and all of my attempts to mount a usb flashdrive (to get the sourcecode from and compile to) has failed.
Basically I can run the virtual machine, but it can't communicate with anything I can think of. (A floppy disk would probably work, but the space limitations make the usefulness, well, limited.)

Here are some details:
I have allowed access to the internet for VMware Player in my Firewall (Norton Internet Security 2005). The Ethernet setting I'm using in VMware Player is NAT, but I have tried the others as well. I haven't tried to change any settings in Debian.

"Client for Microsoft Networks" is checked in both VMNet 1 and VMNet8, and I tried unchecking and checking all of the boxes as someone else did to make it work. I pinged "debian" and the ip adresses I got from "ifconfig" in Debian with no luck. A search for all computers in the network (*;*) only found actual computers and not the virtual machine.
I had the virtual machine running all the time when I searched and tried to find iton the network.

About the flashdrive: The mount command on Debian says
Code: [Select]
usbfs on /proc/bus/usb type usbfs (rw)but when I navigate there I can't find my files. It is probably just my lack of knowledge of Linux and Debian that causes this problem, so it should be easily solved.

I appreciate any replies and/or solutions.

Btw, I run Windows XP Home Edition SP2.