Rockbox Technical Forums

Installation / Removal => Manual Installation => Iriver - Installation/Removal/Flashing => Topic started by: tigertom2003uk on January 20, 2011, 05:38:12 PM

Title: -32 ATA Error, Need help!
Post by: tigertom2003uk on January 20, 2011, 05:38:12 PM
Hi all,
I have just upgraded my H340 with a Toshiba MK2431GAH HDD (240GB HDD) used a ZIF to IDE adapter which works fine on my pc, I have done all the correct things i.e. the HDD is in FAT32 format, has no partitions on the drive & is set primary.
I now have installed the drive into my device & now I get a error message on the bootloader saying: -32 ATA Error.
I have tried to flash the device with the Rockbock bootloader again, still same error message.
I also tried to boot into the iRiver firmware, that works fine in everyway, just can't boot into Rockbox, any idea's anyone?
Regards Tom.
Title: Re: -32 ATA Error, Need help!
Post by: Chronon on February 21, 2011, 07:15:34 PM
I can't find any definitive cause or fix for this.  In cases where neither Rockbox nor the iriver firmware will boot it seems to indicate a hardware failure.  Since iriver firmware boots fine the case isn't so clear.  Here is one person who reported similar behavior:,22602.0.html

There's also a case of this error being fixed by some changes to the bootloader for H1xx:,16423.0.html

It could be that the bootloader has a bug.  Unfortunately, recovering from a bad bootloader requires specialized hardware, so it's a bit dangerous for most users to experiment with making changes.

I'm also not sure of how to proceed to confirm the cause of this error.