Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: bayview95 on January 19, 2010, 03:59:02 PM

Title: Sansa e280 brick
Post by: bayview95 on January 19, 2010, 03:59:02 PM
I apologize in advance for missing any details in previous postings.

I have a Sansa e280 that does not have any display, is not recognized properly under Windows, but shows power through a blue ring.  Through multiple postings, it was clear to boot into Ubuntu and try using the e200Tool following this guide - http://fixmysansa.blogspot.com.  After running lsusb (step 4 under step C), I do not see SanDisk, but rather the following...

Bus 002 Device 008: ID 6666:e200 Prototype product Vendor ID
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 003 Device 003: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I believe the first device, with ID 6666:e200 is my e280 MP3 player.  Since it did not match the instructions, I looked for other information.  That brought me to several sources here, especially content that referenced that my device is in pre-boot mode and I should run "./e200tool init" followed by "./e200tool i2cprogram i2c-e280.bin".  Unfortunately, I do not get the expected results.  I get the following (when I am lucky)...

ubuntu@ubuntu:~/e200tool$ sudo ./e200tool init
e200tool v0.2.3-alpha (c) by MrH 2006, 2007
Searching for device 0781:0720 ... 9 8 7 6 5 4 3 2 1 0 not found!
Searching for device 0b70:0003 ... found!
Initializing USB stub (4780 bytes) ... done!

ubuntu@ubuntu:~/e200tool$ sudo ./e200tool i2cprogram i2c-e280.bin
e200tool v0.2.3-alpha (c) by MrH 2006, 2007
Programming i2c rom (address=87) range 0x0000-0x2000 from 'i2c-e280.bin'
Searching for device 6666:e200 ... found!
Uploading at 0x2000
Uploading done!
Programming, please wait...
Programming failed (-32, Broken pipe)
*DANGER*, player might not be bootable now! Please retry!

Anytime I run the "./e200tool recover BL_SD_BOARDSUPPORTSD.ROM" command while pressing the REC button on the player, the device is not found.

At this point, I really don't know what to try.  I am hoping there are other things I can do to help recover from this point and actually start seeing the new folder under File System/Media. 

Thank you in advance for your help,
Tim Harris
Title: Re: Sansa e280 brick
Post by: Chronon on January 21, 2010, 03:02:09 PM
You may be out of luck.

Here is the "unbrick" page in our wiki: http://www.rockbox.org/wiki/SansaE200Unbrick#Pre_boot_Mode
Here is the e200tool page: http://daniel.haxx.se/sansa/e200tool.html

Unfortunately, I cannot offer any guidance in the event that "e200tool i2cprogram i2c-e280.bin" fails.  There is this rather ominous statement in bold on the e200tool page:
Quote
SO IT SHOULD BE OBVIOUS THAT WHILE DOING THIS MAY (WITH SOME LUCK) FIX THE I2C ROM, IT MIGHT VERY WELL BRICK THE PLAYER EVEN FURTHER! DO NOT TRY THIS UNLESS NOTHING ELSE WORKS!