Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: marsrover on June 09, 2011, 05:21:35 PM

Title: Sansa E200 V1 odd wheel beheivor (software related)
Post by: marsrover on June 09, 2011, 05:21:35 PM
So this problem is kinda two problems in one.
First (and greatest) is I have taken apart my player several times to fix the wheel. Cleaned it, put it back together, works fine. Only the little trailing tabs fell off. (they all fell off) But it works fine, but only for a while. After I load a few songs, screen goes off, I change track (normal operation) It will randomly stop taking input from the wheel. Doing a regular reboot does not fix it. I have to hold down the power button longer to do a full reboot, then the wheel works fine again. For a while.... bout 20mins of use later, goes bad again (repeat reboot cycle, pull hair out... etc)
Second problem that may or may not be related to the first problem.
When playing a song (any song) sometimes it will stop mid song... then start again. Like it's running out of RAM or something. I've had this player for about 7 years (using it every day) could it be that the memory is just going bad? Would that also explain the glitch in rockbox in the first problem?
Anyway, sorry for the long explination, it's just a bug that's annoying.
Title: Re: Sansa E200 V1 odd wheel beheivor (software related)
Post by: saratoga on June 09, 2011, 05:54:40 PM
The debug menu has a buffering screen that shows the status of the various buffers.  You can get an idea of whats happening by watching them when it glitches.  Also checking the disk for errors and updating to the latest build if you're running an older version aren't bad ideas.

Also, you've probably had the player no more then 5 years, since the e200 launched in 2006 :)