Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: Gravitonx on November 17, 2011, 09:08:00 AM

Title: Iriver H320 CFMod ATA error: -80
Post by: Gravitonx on November 17, 2011, 09:08:00 AM
I've tried to do CF mod yesterday without success  :(.
What I've done:
1. I installed patched Iriver firmware ver. 1.29k via native iriver Firmware update
2. Install latest rockbox using same FW
3. Copy rockbox to CF card Transcend 32Gb 133x
4. Replace HDD by CF card using adapter
5. When tried to boot Rockbox it shows error:
 ATA Error: -80, please connect usb cable and press a button.
I connected USB cable and nothing happened.
But then I reset device, connect it to the usb cable without starting rockbox
In this case it showed the same error, but when I pressed a key it connected in usb mode and the cf card became available, I could read and write files.
Then again tried to boot rockbox - again error.

Please advise, what can I do in this situation? Is it connected with the card?

P.S. The same situation is for the H300.hex which was attached to CF Mod guide page. (I also installed it via native Iriver FW update and got the same result as described below)

P.P.S. Sorry for duplicating the theme but in that section it takes too long for answers. Hope here I can receive some help faster.

Thanks in advance!
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: dreamlayers on November 17, 2011, 02:21:46 PM
This appears to be a command failing in set_features, when setting the default PIO mode. (set_features returns -20-0 and ata_init subtracts 60). That command should never fail because it's a simple command that must be supported. However, devices can be buggy. I would remove the error check in the loop in set_features and see if that modified build works.
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: Gravitonx on November 17, 2011, 03:56:28 PM
Sorry, I'm not a developer! Could someone help me with this? And give a rockbox with this fix?

Post Merge: November 17, 2011, 05:55:40 PM
By the way, I've read that the same problem was solved on Iriver IHP-120 by ROM flashing, but I cannot find such procedure for Iriver H300... Even there is no iriver_flasher among the utilities on the H300.. Could someone advise on this?

Thanks in advance!
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: dreamlayers on November 17, 2011, 10:31:20 PM
I wonder where this problem is happening.  If it's in Rockbox on disk, you can try this copy (, which doesn't check for errors after "set features" commands. If it's in the bootloader, then I can't create a new bootloader for you because I don't have one of these devices to test on, and I'm afraid that a bug there would brick your player.

The flashing procedure is described in the manual ( Apparently, you just put the .hex file in the root directory and the original firmware performs this update.
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: Gravitonx on November 18, 2011, 08:36:41 AM
I copied this folder on the CF card.
install the modified bootloader once more just in case.
Now I have the following situation:

# id[00] = 848A
# id[82] = 702B
# id[83] = 500c
ATA error: -81
Insert USB cable and press aa button
then, after a while I see
"No partition found"

What does it mean?

Thanks in advance guys!

Post Merge: November 18, 2011, 11:59:39 AM
Seems the problem was in CF card. Replaced it by Pretec 16Gb 233x and it worked at once.
I think some notes should be written in the CF mod guide page about Transcend 133x.
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: Julian67 on December 17, 2011, 09:14:41 AM
I just had the same error with a Transcend 133x 8GB card.  I tried a very old Kingston Elite Pro 50x 2GB card and that booted fine, all with current bootloader and release 3.10.  The Transcend card also causes problems with two different cameras and several card readers; it's a brand I will avoid in future.

btw this was on H340.
Title: Re: Iriver H320 CFMod ATA error: -80
Post by: jmech on December 21, 2011, 08:10:07 PM

same here with a H320 + Transcend 133x 64GB...don't have a different card at hand but will post if it can be fixed by simply replacing it with a different one.

Title: Re: Iriver H320 CFMod ATA error: -80
Post by: gap736uk on March 19, 2012, 12:53:19 PM
I have a Transcend 32Gb, 400x card and initially I had the -80 error. I then replaced the bootloader with one that I came across that is patched and set to give debug info.. and got the -81 error on that occasion (whether or not I had it formatted as FAT as opposed to FAT32 on the first attempt i'm not too sure... I *think* that that may have been another issue but I've not tested this to verify)

Elsewhere I've read that the issue might be that the bootloader needs some of its ATA settings changed to remove some of the options that are no needed which could be leading to the issue.. but I've not got experience with this. (there is a  technical document available on the web that describes the ATA/IDE side of this CF card, but too technical for me to link this up with how to adapt the bootloader to cope with this card (if if can be done!!) ) .

I have been in touch with someone via Ebay who has done the CF mod on H3**s with the Kingston 32Gb 133x cards sucessfully... however, you can no longer get these!!! and i've not heard good things about the 266 speed version that is now out.

Anyone recommend any higher capacity CF cards that DO work with the H3** CF mod?

Title: Re: Iriver H320 CFMod ATA error: -80
Post by: poulpe63 on October 13, 2012, 07:41:18 AM
OK, I'd got the same problem...
I bought the IDE-CF adapter, a Transcend 32GB 133x and the current firmware 1.29K with the "official" rockbox bootloader.

After several attempts, what I did ?

1) I plugged the original Had disk in the H320.
2) download the already patched 1.31K firmware there :
3) I followed the procedure for upgrading with the h300.hex file  (from there :
4) Then, I removed the Hard Disk, and put the CF+adapter.
5) And, finally, the H320 was started : no more error :), and the boot time is very short :)

Currently, I'm putting all my files in the CF and the H320 is charging.

If I notice something that's not working, I will update that post. (but everything seem fine so far).