Rockbox Technical Forums

Installation / Removal => Manual Installation => Apple - Installation/Removal => Topic started by: Mido on February 23, 2022, 02:50:04 PM

Title: New iPod owners needs help updating old emCORE Rockbox version
Post by: Mido on February 23, 2022, 02:50:04 PM
Hey, I just bought an used iPod Classic 7G 160 GB and the seller asked me if I want him to install Rockbox. I said yes because I hate iTunes. Turned out the iPod I received has quite old version installed and some things aren't working. After I bought it he instantly made a new listing with another iPod 7G so this is probably his business (I have found some older iPod listings of his later).

He probably installed the Rockbox old time ago. It's my first device with Rockbox firmware so I'm afraid of bricking it if I do something wrong. The installed version is "d20185a-151007" with emCORE v0.2.3 r859. As far as I could google, it means no dual boot - Rockbox replaced the stock firmware.

If I checked correctly, the lastest version is 3.15 from 2020. I asked the seller how can I update it to the latest version. He said he doesn't know and "maybe ask someone with the same version".

Help  :'(

EDIT: Managed to uninstall it with this guide https://freemyipod.org/wiki/EmCORE_Uninstallation