Rockbox Technical Forums

Third Party => Repairing and Upgrading Rockbox Capable Players => Topic started by: canuckken on May 01, 2017, 07:27:48 PM

Title: Sansa e260 (bricked)
Post by: canuckken on May 01, 2017, 07:27:48 PM
A newbie here. I realize this has been covered many times however I cannot find many new or updated threads that contain links to the necessary files needed to repair my daughters bricked Sansa e260 v1 player, most links are old and not working.

The player had a recent Rockbox v1.4.0 installed and was working great until my daughter purposely or accidently formatted the recovery partition. Now the player displays the blue ring with a black screen and will not show up on Windows 10 when plugged in, even if you start it in recovery mode. Device manager recognizes the player as the tango media device but that is all.

I am an old fart and a bit of a dumbass on a computer so is there anyone who repairs these players or at the very least can give me the needed files or give me a working link with instructions. At this point, I would be more willing to pay someone to have it unbricked as I am worried I may screw it up even further.
Title: Re: Sansa e260 (bricked)
Post by: saratoga on May 01, 2017, 07:38:12 PM

Note that you will need to boot into Linux first, or possibly setup a VM with USB pass through.
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 02, 2017, 04:32:38 AM
Thanks but it is not working for me. I need to use the second method of putting the player in manufacturing mode by turning on hold/lock button + holding the select button and plugging in the usb cable. I tried several times and even altered the method but Ubuntu is not detecting a new usb device. In windows 10 the player gets detected in device manager as tango media but it never shows up as a usb device. While running Ubuntu if I plug in a flash drive it gets detected as a usb device, just not the Sansa.

If that is not enough there is the issue of running the e200tool do I need to put the files in a particular folder and just open terminal and insert the codes. There is also this... "You may need to make e200tool executable: for this type chmod +x e200tool".
I have no idea what I am doing in Ubuntu as I have never used this operating system.

I suspect none of it really matters if I cannot get Ubuntu to detect the player.
Title: Re: Sansa e260 (bricked)
Post by: gevaerts on May 02, 2017, 08:43:21 AM
First of all, what do you mean by "if I cannot get Ubuntu to detect the player"? In  the state your player is in, it not showing up as a disk or an MTP device is expected

So in short (please read every step completely before starting)
* Start your ubuntu system.
* Download all files you need ( (, (, ( I'm going to assume the files end up in your "Downloads" directory. If they're somewhere else, adjust what follows accordingly.
* If you're doing this in a virtual machine, also download the files in Windows. You may need them later on that side.
* Open a terminal
* Type "cd Downloads" (and press enter) to go to the Downloads directory in the terminal
* Type "chmod +x e200tool" and press enter (This tells the system that "e200tool" is an executable file, i.e. a program)
* Put the player in Manufacturing mode as described on the SansaE200Unbrick page (although the player may already be in this mode)
* Type "sudo ./e200tool recover BL_SD_boardSupportSD.rom" and press enter. While doing this, press and hold the "record" button on the player until the player starts recovery mode (this will show something on the screen).
* When the player is in recovery mode, it will appear as a USB disk. If you're doing this from a virtual machine, the USB disk may appear in Windows instead of in Ubuntu. This is fine. Copy BL_SD_boardSupportSD.rom and to that disk.  Do not do anything else with this disk. Do not copy other files to it, or format it, or anything. This is important!
* Safely unmount/remove the USB disk.

With some luck, this should have put the original firmware back. Especially the actual recovery may need a few tries to get all buttons pressed at the right time, but it should work. If you have further questions, feel free to ask them. Screenshots or exact transcripts of what's in the terminal may help.
Title: Re: Sansa e260 (bricked)
Post by: gevaerts on May 02, 2017, 08:50:07 AM
By the way, are you sure the issue is that the recovery partition is corrupted? A fairly common issue with the e2x0 series is that when they get a shock (such as when they're dropped), the flash chip gets loose. If that's the case, remove the back of the player (there are four screws), and look for a square hole around 1cm across with black (or dark gray) dense foam under it. Press that down firmly. If it clicks into place, this was the issue and you should be all set again.
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 02, 2017, 09:08:22 AM
I read about the chip problem and it is definitely not that. I checked it and pushed on it and still the problem persists. My daughter did format the recovery partition and immediately after that it stopped working. I will read your instructions and give it another shot. I just assumed that the player would show up as a usb device after starting in manufacturing mode because the instructions said it would.

I am surprised someone has not made a step by step how-to YouTube video. It helps when you can see things being done.   
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 02, 2017, 10:02:50 AM
So I have done what you have written and this is what I am facing now. As you can see everything is in the download folder. Also, no internet connection is needed for this to work I hope because I have not installed the wireless drivers on Ubuntu as it is a pain in the you know what and I am unable to connect to ethernet.
Title: Re: Sansa e260 (bricked)
Post by: gevaerts on May 02, 2017, 11:58:51 AM
OK, I think I know what's going on. That version of e200tool is built as a 32 bit shared binary, and your ubuntu setup is probably a 64 bit setup without all the compatibility stuff.
If that's the case, the version at ( should work, so try that one instead

Apart from needing the files I linked to in my previous post (and the new e200tool linked from here), you don't need anything from the outside world, so you don't need a network connection for any of this.
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 02, 2017, 05:40:31 PM
I really appreciate you hanging in there with me gevaerts, I am getting a little further with each try but now I have another issue. Everything goes smoothly until the very end. I copy the 2 files to the 16mb disk and they show up in that disk however when I eject the disk and restart the player I still have a black screen. While the disk was showing in Ubuntu I did have the "welcome to recovery mode" showing on the player.

Am I not unmounting the 16mb disk properly or is there another step I need to do. This is a more clear and uncropped shot of what is going on because of the size restrictions on attachments. The attachment is just of the terminal but the link shows the copied files.
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 02, 2017, 08:12:41 PM
I am a happy guy. I got it working thanks to your instructions gevaerts. The one thing I needed to do that I had neglected was to make the sansa.fmt file and place it on the disk. Once I did that everything worked. Again thank you very much for your help. I could not have done this without you. Cheers :)
Title: Re: Sansa e260 (bricked)
Post by: gevaerts on May 03, 2017, 04:07:49 AM
Oh, right... I forgot all about the sansa.fmt file. Sorry about that
Title: Re: Sansa e260 (bricked)
Post by: canuckken on May 03, 2017, 04:43:46 PM
NP at all, besides your great instructions you also provided the link that had the instructions that mentioned the sansa.fmt file.
I should have made a video but I already uninstalled Ubuntu so that won't likely happen now, plus I suspect the Sansa e200 series players are disappearing seeing how I have had mine since 2006 which my daughter is now using. They are still a decent mp3 player though and I recently purchased a high capacity battery for it. It will probably last another 10+ years.
Title: Re: Sansa e260 (bricked)
Post by: ljones on May 21, 2017, 01:48:36 PM
Got an old sansa e200 here device though unfortunatly I think it is well and truly dead.It's been in the bottom of a drawer for a few years now(!) though I do have another e200 device so I could charge its battery up again (the device has been bricked for all that time as well). So I tried pulling up some information from this website and forum but haven't got anywhere. Unfortunatly my device is pretty much (I think) totally bricked!

So in one last attempt I've been trying to debrick my decice on my linux/debian box.

When powered on only the blue ring light comes on. Trying to get into recovery mode does nothing (switch set to lock, hold down record).

BTW I have been following these instructions -

I can get into recovery mode and this is what dmesg reports:

Code: [Select]
[13326.284110] usb 3-3: new full-speed USB device number 5 using ohci-pci
[13326.471227] usb 3-3: New USB device found, idVendor=0781, idProduct=0720
[13326.471234] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[13326.471237] usb 3-3: Product: Tango Digital Media Platform
[13326.471240] usb 3-3: Manufacturer: SanDisk

I then tried to follow the instructions and ran

Code: [Select]
./e200tool recover  BL_SD_boardSupportSD.rom
That produced

Code: [Select]
./e200tool recover BL_SD_boardSupportSD.rom
e200tool v0.2.3-alpha (c) by MrH 2006, 2007
Searching for device 0781:0720 ... found!
Initializing USB stub (4780 bytes) ... done!
Writing 'BL_SD_boardSupportSD.rom' to address 0x10600000
Searching for device 6666:e200 ... 9 found!
Write at 0x1065fc38
Write done!
Running from address 0x10600000
Searching for device 6666:e200 ... found!
Execution started!

While writing I held down the record button. However once it has finished working and this is where it fails instead of a recovery partition appearing or anything on the screen appearing the blue ring light goes off for a moment, but then comes on and then nothing.

dmesg then just says:

Code: [Select]
[13397.940174] usb 1-3: new high-speed USB device number 52 using ehci-pci
[13398.089134] usb 1-3: New USB device found, idVendor=6666, idProduct=e200
[13398.089142] usb 1-3: New USB device strings: Mfr=0, Product=0, SerialNumber=0

I think this poor old sansa is well and truly dead!

Title: Re: Sansa e260 (bricked)
Post by: saratoga on May 21, 2017, 01:53:52 PM
Double check that the memory daughter board hasn't come loose.   On the old sansas they could separate in which case the device would appear bricked because the memory was disconnected. If it is out of the socket, just pushing it back in will fix the player.
Title: Re: Sansa e260 (bricked)
Post by: ljones on May 21, 2017, 01:56:54 PM
Yep *nods did that before I tried all the e200tool stuff. I'll check again but it seems to be pretty much on there.

Update :Tried but no joy, but here are some results. Just out of intrest (I have two sansas here, one good one bricked) I tried the memory board from the good sansa in the bricked and ..... same result. But the memory board from the bricked sansa in the good sansa seemed to work - it loaded the deault sansa firmware. So I guess the problem is not in that board but somewhere else.

Title: Re: Sansa e260 (bricked)
Post by: whenevertobe on November 04, 2021, 01:26:13 PM
The links to daniel.haxx no worky.

"The requested URL was not found on this server."

Is someone able to post an updated link?
Title: Re: Sansa e260 (bricked)
Post by: Bilgus on November 04, 2021, 02:41:42 PM
Haxx has recently stopped hosting stuff for us so they might still exist but hopefully someone has it at the ready
Title: Re: Sansa e260 (bricked)
Post by: Bilgus on November 04, 2021, 02:45:50 PM
I have the pp5022.mi4 at home don't know about the others
Title: Re: Sansa e260 (bricked)
Post by: vitt13 on November 04, 2021, 06:03:18 PM
Saved by Wayback Machine
Title: Re: Sansa e260 (bricked)
Post by: whenevertobe on November 11, 2021, 01:21:03 PM
Wow! Cool.

Thanks guys, everything's working now.