Rockbox Technical Forums

Support and General Use => Hardware => Topic started by: RolesG on August 05, 2021, 03:43:44 AM

Title: Cannot write to Ipod Mini (1g)
Post by: RolesG on August 05, 2021, 03:43:44 AM
I have this old ipod mini that I've modified with an SD card/CF adapter to have 64 gigabytes of storage. It's worked great with the default ipod software for about a year but all of a sudden it seems, it stopped writing. I bought some new music, tried to sync the music to the ipod with itunes and it wouldn't go on. I thought that was odd. So I thought it might be an issue with itunes since it's so buggy on windows (i'm on windows) I installed RockBox, which worked fine, and plugged in my cable, and the computer wouldn't even read it as a disk. I thought to myself, no problem, i'll just boot in disk mode. I did so, now it shows up on the computer, and i can read files on it, but when i try to write to the ipod it either tells me to "connect a drive to G:" or it'll get about 15mb in and then stop and won't go any farther.

Here's what I mean: https://imgur.com/a/aNz13pd (https://imgur.com/a/aNz13pd)

Also, when i boot my ipod into rockbox, i can't read it as a drive as explained above but additionally it will KERNEL PANIC after i eject. No idea what's causing that. Currently the only way i can see stuff on the ipod is in rockbox on the ipod, or in disk mode/standard ipod firmware on my pc (i can read it as a disk in the regular ipod firmware)

I should note that before installing rockbox my ipod has been wiped, there's nothing on it except rockbox.

I have no idea what is going on, any help would be appreciated. I'm new here, advice is welcome.
Title: Re: Cannot write to Ipod Mini (1g)
Post by: RolesG on August 05, 2021, 03:48:27 AM
I should add: Please email me if you have a reply, I don't often check forums when I should. An email will get to my attn faster. thx.
Title: Update:
Post by: RolesG on August 05, 2021, 07:52:21 PM
During one of the kernel panics, I was shown an error message that I could actually read, it was saying something to the effect of "Could not write to: (data block)" which led me to believe that the SD card I'm using has gone bad. I opened up my Linux laptop, opened GParted, and plugged in my Ipod. (I used GParted because it can tell me more about a disk than the windows disk utility.)
Gparted told me that the filesystem was missing/corrupted and that it couldn't recognize a filesystem at all. So I formatted the disk as FAT32, tried to restore the ipod and now it won't get past the sad folder of death.

So I guess my SD card is borked.

I'm going to open up my IPod and see if I can format/write to the SD card while it's out of the IPod and verify that the card is indeed dead. I guess if it is then I'll buy a new card...

I guess until then this thread will be dead unless the SD card is fine in which case it might be my ipod.