Installation / Removal > Sandisk - Installation/Removal

Sansa 8gb e200 in 'pre-loader' mode and not working


I bought a new Sandisk Sansa 8gb e200 yesterday.

Being naturally curious I wanted to see what Rockbox looke like, with a view to using it instead of the default GUI.

I followed the Rockbox instructions and all worked well - I had Rockbox up and and running on my Sansa.

When I plugged the USB cable in, the Sansa went to an image showing a USB cable but my PC didn't
see any new USB connection. My PC is running under Fedora Core 6 and usually all new USB devices are
automatically detected. Indeed, the Sansa was automatically detected by FC6 when it running with Sandisk's firmware.

I thought that this wasn't a great problem, as I had read on the web-site that Rockbox's firmware dual-booted
with Sandisk's. I went through the dual-boot process but got a message saying that a file was missing and couldn't boot.

By now I was panicking and I hastily read the website and found a page that said by going into recovery mode and adding a  'OF.bin file' it would dual-boot properly.

So, after some messing around I found how to go into recovery mode, which worked and got me a USB connection to the recovery mode partition. I added the OF.bin file and tried rebooting - nothing! It won't turn on. It won't reboot. Just a black, empty screen.

Having read MrH's website I think that I am in 'pre-bootloader'. When I do an 'lsusb' from my command prompt, I see:

Bus 001 Device 005: ID 0b70:0003 PortalPlayer, Inc.

I have also downloaded and compiled the e200tool, but when I try and use it, I get;

[root@localhost e200tool-src]# ./e200tool i2cdump yy.rom
e200tool v0.2.3-alpha (c) by MrH 2006, 2007
Dumping i2c rom (address=87) range 0x0000-0x2000 to 'yy.rom'
Searching for device 6666:e200 ... 9 8 7 6 5 4 3 2 1 0 not found!
[root@localhost e200tool-src]#
[root@localhost e200tool-src]#                                          

Can anybody help?

Where did you see that putting OF.bin in recovery mode is supposed to fix the problem you had? These instructions are incorrect, and I need to remove them or fix them before they cause this problem for other people.

I have just had a look at all the web pages that I read and I would
have to be honest and admit that I just did the wrong thing.

I can'tfind any page that tells you to to add OF.bin when in recovery mode.
In fact, reading the pages again, they warn you not to do anything
as stupid.

Do you think there is any possibility of recovery?

I have just re-run the e200tools utility (after re-reading the web page) and the Sansa has sprung back into life. Now I will go and find out how to dual-boot properly.

Thank you

I'm glad you got it fixed, and it's a welcome site to see someone get it fixed without 40 pages of walking them through things. :)

Thanks for verifying that it wasn't the pages. I'm always worried something isn't clear enough, or written in an ambiguous way that leads to something like this.


[0] Message Index

Go to full version