Third Party > Repairing and Upgrading Rockbox Capable Players

Help, ATA pbs...

(1/3) > >>

it doesn't want to start : it writes "ATA error : -52 Press ON to debug"   What's the matter ??

It also writes "*PANIC* ata : -52" and red LED flashing... :'(
Please help me !

My batteries are full... and neither USB mode nor "normal use" mode are working !

Thank you...

There are some possibilities:

1) Broken batteries - try a fresh set

2) Broken battery connections - try to squeeze the box in different directions

3) Broken hard drive - try it in a laptop

OK, thank you for the piece of advice !

I'd already tried with a new battery set...

The hard drive starts to spin but doesn't "scratch" as it used to do...

I had a week ago an ATA -1 error but it worked properly since that problem...

Thank you for your help !

I think your battery connectors might be broken. What happens if you squeeze the box?

It seems not to do anything...Nothing happens

The HD is still spining but doesn't read !

I hope my data not to be lost.

Can I fix it myself ? If not I will send my unit back to archos... What could be the cost of such operation ?

Thank you !


[0] Message Index

[#] Next page

Go to full version