Installation / Removal > Cowon - Installation/Removal

serious installation problem


Hello there,

i just tried to install Rockbox on my IAUDIO X5 from Cowon, and
now it is nearly dead  :o  :o
According to the documentation in
i first installed the bootloader by downloading the file 'x5_fw.bin', connected the
X5 via USB to the PC, put this file into the root directory of the X5, switched the X5 off,
disconnected the USB cable, connected the external power supply, switched the X5 on:
it says something with 'flashing the firmware', seems to be fine.
The next step, according to the docu, is to install the firmware by extracing the contents
of the file '' to the X5.
But i cannot do this because: after switching the X5 on, it now says:

'Rockbox boot loader
Version 2
Batt: 3.7 V
Loading firmware
Result: -l '

Then it TURNS OFF immediately !!
I tried to press any button, connect the USB cable or not, connect the
external power supply or not, the result is the same.
So i cannot establish any USB connection any more !
I found another thread in this forum where a similar problem is described,
but there the X5 starts when connected to the USB.
Should i try another PC with another USB, or what can i do ?


Insert the USB cable *before* turning on the player.

Connect via USB using the *subpack*, not the side 'USB Host' port. The side port is for USBOTG only (ie, connecting digital cameras, memory sticks, etc). Always use the subpack to connect to a PC.

uhh, the subpack.. that was it, thanks !  :)
maybe one should mention this in the docu,
because for sure im not the only one who made this
thanks again,



[0] Message Index

Go to full version