Third Party > Repairing and Upgrading Rockbox Capable Players

help with USB

(1/2) > >>

My Jukebox 20 works fine until I try to plug it into my computers via USB port. I usually just go to my computer and the jukebox shows up as "Jukebox drive E".  Now it shows up as Drive F and I am getting the error disk in drive F: is not formatted, would you like to format now? I say no.
I cannot explore the drive or anything. What do I do? thanks, jon :'(

Are you plugging it into your computer or are you plugging it into a usb hub.  this may be causing the problem.  If not, just try deleting the songs & reapplying them.  That may be your best option.  i hope this helps

I am having exact same issues. I've seen other posts as well for similar. Mine worked great for a long time, then one day..this problem.

I've tried on several different XP machines with same results....however....
when I try it on a Linux FC4 build, it mounts and reading/writing files works great. So XP has issues it seems , and Linux does not. I can't reformat the drive as I will lose songs because I only have a small linux partition that can't possibly save almost 20GB of files. SO I'll figure something out. Bu tthis is certainly a problem with no answers that I've seen that work for XP.

one thing I might try is reverting back to Archos OS instead of Rockbox to see If that lets me access the files again, if so, then copy them to HD on XP, reformat JBR and reinstall latest RB, and try again. I'll let u know what happens after I try it..

OK folks...
I've tried going back to Archos luck..same situation. So it is not Rockbox OS. I believe it is something that was introduced in SP2 for XP as that's about the time I remember it ceasing to work on XP. To test this theory I will later try installing Windows 2000 and see what happens.

but for now...
I have been able to mount the drive in Linux FC4 no problems and read write files with ease. For those of you that can use/access Linux in the meantime, this seems to be your only recourse. And if nothing else works with XP, this is going to be the only way I access the files on my JBR 20GB from now on.

I am tending to blame MS for now for changing something to do with Mass storage USB devices, though what it is, I don't know. All I know is that it used to work without problem, then one day it stopped and produced the "Do you want to format drive" error that several of us are complaining about.

Will Update later after I try Win2000 pro...till then.  


[0] Message Index

[#] Next page

Go to full version