Rockbox Development > Starting Development and Compiling

error during patch

(1/2) > >>

$ patch --binary -p0 < margin.patch
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|---- ./apps/gui/gwps.c.orig        2006-07-14 18 (blablabla)
|+++ ./apps/gui/gwps.c              (blablabla)
File to patch:

this is what i got after type it.
wat's wrong?
i thought there's a problem in the patch file itself
so i tried with other patches but they didn work too
if i skip the file above, other missing files come up again and again

somebody help me  :'(

try changing the  -p0 parameter to either -p1 or -p2

still not working.. :'(

You are running the patch command from the /rockbox/ or /rockbox-devel/ folder, right? Where your sources are?

do this make a folder called patches.. double click the patch file and find out that files are needed to be patched and drag those files in the patch folder then do this...

cd patches
patch < margin.patch

p.s this is how i usually do it there is a easier way though but i like this way.


[0] Message Index

[#] Next page

Go to full version