Installation / Removal > Apple - Installation/Removal

Problems installing Rockbox on 7th gen with SSD swap. Is there a solution?


I have a 160gb 7th gen in stock form that I run Rockbox on to play flac files. Recently picked up a pre-modded 7th gen with a 256gb SSD.

I’ve restored it in iTunes and then attempted to install Rockbox but am running into issues.
This is especially annoying as my music library is flac which isn’t supported by iTunes and so I basically can’t use the stock firmware unless I convert every file :(.

Using the utility I’ve tried the stable build and daily build installs. (Installing everything but the bootloader in one go and then installing the bootloader separately in a second run)

When installing the  boot loader it hangs on trying to remount. I need to manually restart the iPod and put it into disk mode which then allows the install to finish to 100%.

This all seems positive until I try to reboot the iPod into rock box where I am greeted with the below:

“Rockbox boot loader
Version 1.0
Battery status ok: 4197mv
ATA error: - 2147483605

Hold menu + select to reboot
Then select + play for disk mode”

Is there a build or an install sequence that will let Rockbox work on this iPod with the SSD?

I was hoping to take this thing with me on an international trip next week but this is looking increasingly unlikely.

...What kind of SSD is this?  Specifics really matter here.

...That error means we weren't able to successfully communicate with the storage device at all.  (From that error, I think the ATA_IDENTIFY command is failing)

The majority of the "SSD" related work went into the <6g series, but the 6g+ uses a different ATA controller (and driver).  I tried to make sure all relevant changes were in both but I've not heard of any outright failures to even talk to the storage device until now.

What is possible/likely here is that this problem has already been fixed but the actual "bootloader" build is quite ancient and probably needs a new build.

I have an updated bootloader build you could try out.  I can't promise it will fix your problem, but either way we will learn something.

(This particular build has passed basic "it boots on a stock ipod6g" tests)

...If it solves this problem, we learn that we need to make this one live.  If it doesn't, then we learn that the problem still exists and needs to be diagnosed.

(Oh, the specifics of the SSD still matter -- You mentioned elsewhere it's an mSATA adapter; which model? And what is the actual model of SSD plugged into the adapter?)


[0] Message Index

Go to full version