Support and General Use > Hardware

Hifi Walker H2 Won't install Rockbox


I've tried installing Rockbox through the utility app and it keeps saying "No mountpoint given"

me too

I did finally manage to get past that problem, but only on my Mac Mini, not on my Mac book, and I'm not sure I don't know if I can give you a receipe. I'm very inexperiencedwith Rockbox since using it on a Sansa and some other other player 10 years ago. There are doubtless many other Forum readers who kno maor, I was just tinkering After finally cutting out the silly version update cycle, I did get Rockbox Utility (apparently 1.5.0) to recognize my Hifi Walker H2. Similar montpoint problem, then put empty into my download cache path so system default would be used instead. That somehow allowed the utility to find my H2 and offer to install Rockbox. The Utility window looked lik the capture That I will try to attach. However, at this point I was afraid to pull the trigger because I was sure what might happen and, moreover, whether I could undo it if I did not like the results.  I encourage your to try it and let me know. I'm still not sure about how I finally got a "mount point", and I'm uncertain about lots else, too. Good Luck! I'm Looking forward to hearing your experiments with an install.

Ive tried installing it also. I can choose a firmware file and then the program crashes before installing

I did finally "pull the trigger" and tried installing ROCKBOX with the utility. The good news I that I did eventually manage to use the utility to uninstall Rockbox and get the H2 to see the music on my microsd card. After the install I ejected it and when I rebooted it did a database update and the the interface was unchanged. It seems to still be the stock (1.7) firmware, except that now the player  did not see anything on the "TF card", until I used to RB utility to remove "all" RB files. After rebooting into my old firmware I could once again see the music on my microsd card. The player is functional again, but a file named "rbutil-cache" remained on the card. I reconnected the player via usb and deleted this file, then ejected it again and rebooted the player. After several minutes updating music, the player seems back to normal, unchanged afaik, and still sees and plays my music files.
I've already, in another post, made a disclaimer that I don't know what I'm doing, but nevertheless thought I should post my experience, which might be useful for others. Maybe there is something I don't know about booting into Rockbox after the install. I would appreciate any relevant information from others and might even try again just to experiment. The stock firmware isn't terrible, but it's tedious to navigate even a relatively small, 64gb card of music files. I have bigger cards I hoped to use but have given up on that plan. Thanks for any feedback!


[0] Message Index

Go to full version