Support and General Use > User Interface and Voice

The new 'reboot' shortcut type

(1/2) > >>

I just now tried adding a 'reboot' item to my shortcuts.  It triggered a shutdown but not a reboot.  Maybe I'm not properly configuring the entry in my shortcuts.txt file?  This is how it appears:

type: reboot
name: Reboot
icon: -1

This is on a 7th Gen iPod Classic (MC293LL/A) running dev build 9d3b012ac0-240513.  I'm wondering if the ~20 seconds it now takes for the Classic to shutdown is somehow timing-out the reboot?

Now I have installed the same dev build and shortcuts.txt file on an iPod Video 5.5 Gen (MA444LL/A) and the 'reboot' shortcut works on that device.  Quick shutdown, no time-out?

A trick I used in the past is to create a file shortcut to .rockbox/rockbox.ipod which will do a warm restart.

Huh, I don't have an iPod classic, specifically, to test this myself. At first glance, it does look like rebooting is implemented for it, though:

I just now tried it again with my Classic:  "Shutting down..." is displayed for about 20 seconds and that's it - no reboot.

I also tried rockbox_dev123's suggestion:  I 'played' the /.rockbox/rockbox.ipod file and my iPod rapidly shutdown and rebooted with no delay on the shutdown, as opposed to the conventional, newly implemented slow shutdown.

Could there be a time-out issue?


[0] Message Index

[#] Next page

Go to full version