Installation / Removal > Rockbox Utility

Both versions of the Rockbox utility for linux do not work on Mint. What next?


I have used Rockbox a long time ago on Trisquel, which is based on Ubuntu and it worked great. I am now on Mint these days, which is also ubuntu based, and nothing works.

My old player broke, I got a new one, I went to install Rockbox on it so I went to get the Rockbox tool. I see that under 'Linux' the tool comes as something called "appimage" and since I don't know what that is I assume it's for some other kind of system. I try to find something for Debian-Ubuntu type system. I find the ppa, I follow the instructions to add the ppa. I enter the command to install it from the ppa. It does not work. I get this error:

Cannot add PPA: ''This PPA does not support jammy''.

Okay, that's out of my scope. But my point is that the Debian-Ubuntu version of the Rockbox tool does not currently work on Mint, which is kind of the most popular Debian-Ubuntu family system.

So now I try the other thing. I google around and find out that "appimage" is a program to install programs. Okay. I find some instructions to install the program that installs the program. It goes fine. I open the rockbox appimage file. It opens. It checks for the current version of Rockbox but it never gets past 'checking...' so it seems the rockbox tool cannot get to the internet. I plug in my new device (iPod mini gen 1) and it does autodetect it. I tried to install rockbox and it fails before it can even try to download anything. It instead shows three errors of "Permission Denied" and doesn't give me any more information than that. I've attached a screenshot to prove it.

I honestly have no idea what to do here. One version can't be installed and the other version requires you to install a program to install the program and It's completely broken on install.

I still love Rockbox because it's so much better than the default OS on an ipod, but what do I do here? How do I install Rockbox Utility on Linux Mint?

I've never gotten the appimage version to fully work, I usually recommend resorting to the 1.4.1 version as it doesn't use appimage. Though do run it from the command line with sudo, as it seems to not have relevant permissions without.

Depending on the device you can usually just plug to USB and unzip the proper. rockbox folder to the device

Not the for iPods though

If I remeber correctly, the problem is that the pre-compiled binaries rely on openssl-1.1.
That worked on Linux as long as openssl-1.1 was there.

Since e.g. Linux Mint moved to openssl-3.0, the Rockbox Utility cannot find openssl-1.1 anymore.
There are already several threads on that topic here in the forum...

As I see it, there are three possible solutions, that I found working on Linux Mint:
1) Use the older 1.4 or 1.4.1 version of Rockbox Utility.
2) Copy the relevant files of openssl-1.1 onto your system. This may come with security issues because these are then not automatically updated to newer versions by your system update tools.
3) Build Rockbox Utility for your system yourself, which then uses openssl-3.0. It's actually not that hard.


[0] Message Index

Go to full version